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Installation Guide

This chapter tells you how to authorize and start your SuperGIS 

Desktop 10.
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1 Installation Guide

This chapter tells you how to authorize and start your SuperGIS Desktop
10.

1.1 Authorizing

To open Supergeo License Verifier dialog, click Start > Programs > Supergeo >
License Verifier.
 

 
 
In Supergeo License Verifier dialog, select SuperGIS Desktop 10 and Single
License, and click Next.
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Choose the item “Input serial number to get license file from Supergeo”, enter
the serial number in the edit box and click Finish. The license will be authorized
successfully while “Receiving license file succeeded” dialog box shows up.
 
 
NOTE: To see more information of license authorization, please view the Installation
Guide within Documents in the installation CD. If you choose to license SuperGIS
Desktop with USB License Key, please refer to the USB License Key tab within the
Documents in the installation CD.
  



2

User Interface Guide

This chapter introduces the user interface of SuperGIS Desktop 10 and 

tells you how to modify the interface to an appropriate one.
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2.2 User Interface Guide

  

2.3 Commonly Used Toolbar

Commonly used toolbars are introduced in this section.
 
Standard Toolbar: The toolbar used to manage files and the main window. With
Standard Toolbar, users can open and save files, add new layer and set scales.
 

 
 

Map Toolbar: provides tools for map browsing. For instance, there are "Zoom in/out"
tools for browsing and "Find" tool can query attribute data so users have better
understanding about the spatial data.
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NOTE: To know more toolbars, please refer to Commonly Used Toolbar section of
Overview of SuperGIS Desktop chapter in SuperGIS Desktop 10 User Guide.
  

2.4 Context Help

To know how a tool works, please click  on the Standard Toolbar, move the mouse

cursor ( ) to the tool and click the tool. You will see a description of the tool showing
on the screen.
 
 
NOTE: To know more tools, please refer to Context Help section of Overview of
SuperGIS Desktop chapter in SuperGIS Desktop 10 User Guide.

2.5 Customize

Open Customize Dialog Box

Users can modify user interface and the window of SuperGIS Desktop 10 flexibly. To
do so, please click Tools on the Standard Toolbar > Customize to open customize
dialog box. Function tabs on the customize dialog box include Commands,
Toolbars, Keyboard, Options, Buttons, Scale List, Local and Lock. In the
following paragraph, Scale List and Locale tabs will be elaborated. To know more
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details, please refer to Customizing SuperGIS Desktop 10 chapter in SuperGIS
Desktop 10 User Guide.
 

 

  Utilize customization functions to meet your requirements.
 

Customize Scale List

Scale drop-down menu on the standard toolbar shows the current scales and other
built-in scales that are used to view the map at different scales. If you need more
scales, you can open Customize dialog box and add the scale you want to the scale
list after switching to Scale List tab, and click Close after finishing all the
configuration.
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2.6 Locale

SuperGIS Desktop 10 provides multiple-language user interface. To configure locales,
please open Customize dialog box and select the locale within Locale tab. After
finishing the configuration, please click Close, and all the configuration saved. To
manipulate SuperGIS Desktop 10 with the selected locale, please restart SuperGIS
Desktop while you see the message “You must restart the program to make the
change of language take effect.”
 
 
NOTE: To know more elaborations, please refer to Customizing SuperGIS Desktop
10 chapter in SuperGIS Desktop 10 User Guide.
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2 User Interface Guide

This chapter introduces the user interface of SuperGIS Desktop 10 and tells you how
to modify the interface to an appropriate one.
 
· User Interface Guide
· Main Menu
· Commonly Used Toolbar
· Context Help
· Customize
· Locale
  

2.1 Main Menu

 
File: File saving and opening, map printing and exporting, and SuperGIS Desktop 10
closing, etc.
 
Edit: Map feature editing and finding, layer adding and map screen printing.
 
View: Map view and layout view switching, spatial bookmark settings, toolbar settings
and the SuperGIS Desktop 10 interface settings.
 
Tools: SuperGIS Desktop 10 analysis tools utilizing, including Charts, Add XY data,
Grid Maker, Geoprocessing Tool and Buffer.
 
Selection: Feature selection tools and selection settings.
 
Window: Overview, Magnifier and Viewer functions are included. Data Content
displaying or hiding.
 
Help: Online manual, user guide and version information of SuperGIS Desktop 10.
 
 

11

10

11

12

12

14
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Create and Visualize a Map

SuperGIS Desktop 10 enables users to add spatial data and create 

maps. In this way, spatial data can be displayed in a visualized way, 

experts from diverse domains can comprehend these data more 

easily and have more effective communication with each other.
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3 Create and Visualize a Map

SuperGIS Desktop 10 enables users to add spatial data and create maps. In this way,
spatial data can be displayed in a visualized way, experts from diverse domains can
comprehend these data more easily and have more effective communication with each
other.
 
· Open a Project
· Manage Layers
· Manage Layer Attributes
· Export Spatial Data
· Export the Map

3.1 Open a Project

After starting your SuperGIS Desktop 10, you can click File > Open to select the
project you intend to open on SuperGIS Desktop according to the file path.
 

Configure Coordinate

If you need to start with a new project, we suggest that you configure the coordinate
system of layer set before adding layers. In this way, layers employing different layers
can be overlaid and displayed on map exactly, and the default map coordinates would
be configured as Unknown. If no coordinate system is defined in advance, the one of
the first layer using coordinate system will be specified as the coordinate system of

16

20

27

31

33



Create and Visualize a Map

17

layer set. To set coordinate system, please right click on the layers, select 
Properties and switch to Coordinate System tab.
 

 You can specify coordinate system by selecting any one on the list or adding a new
one or the current coordinate system. It happens all the time that users neglect to
define coordinate system in advance. However, the inappropriate cofiguration of
coordinate system causes errors to display and analyze spatial data. Therefore, we
suggest that users define coordinate system ahead of time to avoied causing errors of
map displaying and data analyzation.
  
NOTE: To see more elaborations of coordinate system configurations, geographical
projections and projected coordinate systems, please refer to Setting Coordinate
System section in SuperGIS Desktop 10 User Guide.
 

Add Layers and Tables

Spatial information describes the physical locations and distributions of objects and
objects’ properties. While using SuperGIS Desktop 10, users can add feature layers,

raster layers and XLS file in Excel format by clicking . To do so, please click File



SuperGIS Desktop Quick Start Help

18

> Add Layer , or click  on Standard Toolbar directly to open Add Layer
dialog box.
 

 
 
In Add Data dialog box, users can select a single or multiple files at the same time,
and the selected layers will be displayed on map subsequently after users clicking the
Open button.
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Add A Layers

To enrich map information, SuperGIS Desktop 10 supports each map to contain
multiple layers. In layout view, the contents of multiple map frames can be shown
together so that a map presents the map data of several areas at different scales.
 
SuperGIS Desktop 10 supports multi-frame. Each map frame works independently,
having extent, scale and layers of its own. Besides, the different map frames can be
dynamically switched.
 
Users can click Edit > Insert > Map Frame to add a new layers in Data Content.

Each  icon represent different layers. If you see two  icons, it means that there
are two layers in Data Content.
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Besides, users can right click on any layers to configure the selected layers as the
activate one.
  
And the manipulations of layers remain the same for users to use new layers. To add

layer into layers, please click   icon.
  
NOTE: In addition to feature layer and raster layer, SuperGIS Desktop 10 also
supports to add image pyramids layers. To see more and elaborate layer settings,
please refer to chapter Setting and Managing Layers in SuperGIS Desktop 10 User
Guide.

3.2 Manage Layers

This section mainly presents how to set and edit each layer and how to manage the
layers. In Data Content, sequence of layers represent represents the order in which
they are displayed on map. To reorder the layers, please drag or double-click the
layers. To remove the layers, please right-click on the layer in Data Content and
select Remove in its drop-down menu. Users can configure layer properties through
tabs within “the layer” Properties dialog box. Please refer to the following paragraphs: 
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Layer Properties Dialog Box

To open layer properties dialog box, please right-click on the layer name in Data
Content and click Properties…
 

  

There are many tabs in the Layer Properties window, each tab is used to configure
specific property of the layer. Take feature layer for example. Names and functions of
the tabs within Layer Properties window are: 

Tab Name Tab Function

Source Set layer name and its path, and add comments.
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Coordinate
System

Select, create, and edit the coordinate system.

Display Set display of the layer, including Visible Scale, Reference Scale,
showing Map Tip or not, Transparency, etc.

Symbology The classifications of data in the layer, used to set Symbol Type,
Symbol Source Field, Symbol Color, etc.

Selection Enable features to be selectable or not, and specify style for the
selected symbol.

Fields Show fields and set hyperlinks of the layer.

Feature
Filter

Allow users to create query expression and decide whether to display
the filtered features on the map.

Relate and
Join

Set how the attribute table is related or joined with other attribute table

Label Set the display of the labels, such as to show or not to show labels, to
specify which field content as text label, to set font and color of the
text symbol.

 
 
NOTE: Properties of raster layer is different to what of feature layer. The example here

introduce properties of feature layer only. 

Configure Symbology

Appropriate symbology benefit map intelligibility and readers’ willingness to read the
map. With SuperGIS Desktop 10, you can choose different symbols or colors to
enrich your map.
 
· Configure Symbol and Color of Symbology
· Symbol Composer

23

24
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Configure Symbol and Color of Symbology

Users can choose diverse presentations of symbols in the layer properties dialog box.
SuperGIS Desktop 10 supports various presentations of symbols, including Single
symbol, Graduated Color, Graduated Symbol, Unique Values, Dot Density, Bar Chart,
Pie Chart and Gradient Color. Each type of layer can be appropriately presented with
specific presentation of symbol. For example, Graduated Color can be employed on
polygon layer to present properties of different area, Graduated Symbol can be
employed on point layer to accentuate differences among features, and Bar Chart can
be employed to present data with multiple properties. By utilizing different
presentations of symbols, the data properties can be presented on GIS more utterly.
 

 
 
SuperGIS Desktop 10, equipping with diverse built-in symbols and symbol colors,
supports users to select symbol and modify symbol color and size. To modify
symbols, please click on the layer symbol in Data Content, switch to Symbology tab
to select presentation of the symbol and modify symbol color and size. To set
advanced configuration of the symbol, please click Properties…  in Symbol Selector
dialog box.
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In Symbol Selector dialog box, users can modify symbol outline and the outline
color.

To know more configurations on layer symbols, please refer to paragraph Setting
Symbology in SuperGIS Desktop 10 User Guide.

Symbol Composer

 Add New  Symbols

In addition to Symbology tab, Display tab within the layer properties enables users
to configure layer transparency, Contrast and Brightness. Besides, users can also
utilize Symbol Composer to create exclusive symbols or add, modify, rename,
delete the existing symbols and gradient colors. Users can follow the step below to
open and use Symbol Composer:
 
Click Tools in main menu > Symbol Composer to open Symbol Composer. In
Symbol Composer dialog box, you can see different categories of symbols.
Commonly used symbols are in files contained within the categories with check mark.
Each file is sorted by its type like point, line, and polygon and so on. Right-clicking on
any file enables users to add new symbol in it.
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                     Add a new symbol in file FillSymbol
 
 

 Add Gradient Color

With Symbology tab in the lay properties dialog box, users can configure Stretched
Color and Graduated Color for color combination of the layer. In addition to the diverse
graduated colors and stretched color built in Symbol Composer, users can add new
gradient colors through Symbol Composer. To do so, please select Gradient Color
Generator file, right-click on Gradient Color Generator and click New > Gradient
Color Generator to configure the new item.
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 In NewItem dialog box, users can click  to add color, reorder the sequence of

colors by  and , and delete the selected color by . Clicking OK, all the
configurations will be accomplished.
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                                      Add new color(s) into the gradient color list.
 
In addition to adding new symbols, users can also modify symbol size in Symbol
Composer. SuperGIS Desktop 10 supports both graduated colors and stretched
colors. To know more relevant content, please refer to chapter Symbol Composer in
SuperGIS Desktop 10 User Guide.
 
 

3.3 Manage Layer Attributes

Each feature contains relevant attributes recorded in attribute table of the layer. The
attribute table of feature layer is designed as DBF for SuperGIS Desktop 10 users and
can be opened with Excel by dragging. To view attribute table on SuperGIS Desktop
10, please right-click on the layer name listed in Data Content and select Open
Table.
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Users can view field content of the feature after opening the attribute table. Please
refer to the picture below for elaborations of attribute table:

 

 

Select Specific Feature

Users can select the specific feature by selecting its attributes. After selecting
attributes od the feature, users can view the corresponding feature on map.
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Besides, features can be selected through spatial query. To see more elaborations,
please refer to section Selecting Features within chapter Querying Map in
SuperGIS Desktop 10 User Guide.
 

Statistics of Attributes

Right-click on the field name and click Statistics…  to open Statistics of All Features
dialog, you can view the staitistics result including Count (counts of features),
Minimum, Maximum, Sum, Mean abd Standard Deviation.
 



SuperGIS Desktop Quick Start Help

30

 

Field Statistics

Field Calculator enables users to do calculation of a certain attribute. For example,
you can calculate population density of a city through Field Calculator with data of
population and the city area. To use field calculator, please right-click on the field
name and click Field Calculator. SuperGIS Desktop 10 provides users with various 
mathematic functions. 
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NOTE: SuperGIS Desktop 10 also provides diverse functions for users to manage
attributes flexibly, such as Freeze/Unfreeze Panes in Excel, Filter by attribute
categories, etc. To know more on attributes management, please refer to chapter 
Managing Attributes in SuperGIS Desktop 10 User Guide.
  

3.4 Export Spatial Data

With SuperGIS Desktop 10, users can export the configured layer as a new layer or
export the configured attributes as attribute table. The following paragraph introduces
how to export layer and its attribute table.
 
· Export Layer File
· Export Attribute Table

Export Layer File

please reight-click on the layer name
and click Export. Subsequently, you
can choose to export features, layer file
or symbology. If you export layer file, all
the settings of the layer like scales,
symbols, colors and so forth will be kept
in existance. It means that all the
settings of the layer will be maintained

31
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while you import the layer file. On the
contrast, if you choose to export
features, layer symbols and colors will
be adjused by SuperGIS Desktop 10 at

random, and the layer scales will be

modified according to settings of the

new project, too.

Export Attribute Table

SuperGIS Desktop 10 also supports to export attribute data in DBF or TXT. To do so,
please open the attribute table ,click Options and Export Data. And you can export
data after specifying its format and storage folder.
 

NOTE: This paragraph introduces how to export feature layer and its attribute table
only. But SuperGIS Desktop 10 supports to import/export raster layer and its
attributes as well. To know the differences of importing/exporting between feature layer
and raster layer, please refer to paragraph Exporting Image Layer in SuperGIS
Desktop 10 User Guide.
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3.5 Export the Map

Before exporting the map, you are supposed to modify feature sequences and specify
the presentation of the features. Section 3.5 will tell you how to modify configurations
of exporting map in brief.
 
· Turn to Layout View
· Sample of The Map Layout
· Layout Tools
· Configure the Print Setup
· Map Elements
· Export Map and Configure the Map Quality
 
 

Turn to Layout View

To edit the map layout, you should turn the map view to layout view. Please click 
View > Layout View.
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Sample of The Map Layout

 
 

Layout Tools

Layout tools work only in layout view window.
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Configure the Print Setup

Print Setup

Before printing the map layout, users need to define the map format and size ahead of
time. To do so, please click File > Print Setup, or right-click on the blank on the
map window and click Printer Setup to open Print Setup dialog box and configure the
print setup.
 

 
 
NOTE: Configurations of layout will be saved with the map in the project. Afterwards,

users can open the project and print the map layout with the configurations.
 

Edit Layout Template

Users can click  on layout toolbar to choose the layout template built-in SuperGIS
Desktop 10.
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Customize Layout Template: Map Frame

To display more map information on one map or show the spatial data of offshore
islands additionally on map, you can configure a viewer window to enrich the map
information. To do so, please insert map frame and add new layers ahead of time, and
switch to the layout view. Subsequently, you can see two map frames in the map

window. To pan map frame, please move the cursor  to the target frame and drag the
frame to the specified position.
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Save the User Defined Template

Users can define templates according to what they require and save the user defined
template for subsequent usage. To save user defined template, please right-click on
the blank in the map window, select Save As Template and enter the template
name.
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Map Elements

Map elements reveal significant information of a map and assist readers in viewing and
comprehending the map. General map elements include Map Title, Scale Bar, Scale
Text, North Arrow and Legend. Follow steps below to add map elements:
 
· Map Title
· Scale Bar
· Scale Text
· North Arrow
· Legend
 

Map Title

Users can utilize the Select Graphics tool ( ) on Drawing Toolbar to click a text
object > Properties or double-click on the element to open Element Properties
dialog box. In Element Properties dialog box, users can modify the text and position
of the map layout title.
 

38
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Scale Bar

Scale bar on map assists users in comprehending the relation between the real
distance of two points and the distance on a map, and also enables users to measure
distance and area on map. To modify the scale bar, please utiilize the Select

Graphics tool ( ) to double-click on the scale bar object, or right-click on the
scale bar object and select Properties… , to open the Element Properties dialog
box of the scale bar.
 

 
 
In the Element Properties dialog box, users can modify scale division. The scale
division configuration is used to define units proportional to the map’s scale, and the
Sub Division configuration is used to divide the defined unit into another proportional
unit. With scale division and sub division configuration, map readers can utilize map
scales in different units to measure a distance or an area on a map. Besides, users
can also modify the unit and the unit number position of the map’s scale. The unit
number can be placed above or below the scale bar.
 
NOTE: If the scale bar is deleted accidentally, you can right-click on blank in the map
window and click Insert > Scale Bar…  to insert a scale bar. 
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Scale Text

Just like scale bar, scale text is used to show defined units proportional to the map’s
scale. To insert scale text, please click Edit > Insert > Scale Text, or right-click on
blank in the map window > Insert > Scale Text.
 

                              Edit Scale Text Properties
 
 
Users can choose to show scale text as relative scales or absolute scales in the
Element Properties dialog box of scale text. Relative scales mode shows scale text
with two different units (e.g., 1 centimeter = 100 meters.) Absolute scales mode
shows scales text with the same units and separates scale texts with a colon (e.g.,
1: 10000.) Users can modify the scale text format through Format configurations in
Element Properties dialog box of Scale Text.

North Arrow

SuperGIS Desktop 10 provides various built-in north arrows for users to edit the layout
map.

To open Element Properties dialog box of north arrow, please utilize the Select

Graphics tool ( ) to double-click on the north arrow object, or right-click on the
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north arrow object and select Properties… , to open the Element Properties dialog
box of the north arrow.

 

                                                 Edit North Arrow Style
 
 
SuperGIS Desktop 10 provides users with various styles of north arrow in Element
Properties dialog box of north arrow. Besides, users can change color of the north
arrow through Color configuration and rotate the north arrow through selecting rotation
value or entering the rotation value by Rotation configuration. Users can see the
defined north arrow with selected style, color and configured rotation value in 
Preview. To accomplish north arrow configuration, please click OK.
  

Legend

Legend is a map element in layout view. The Element Properties dialog box of
legend is used to configure and edit the legend on map layout. Through configurations
within Element Properties dialog box of legend, users can determine whether to show
title and content of the legend, which layers to be displayed as legends and legend
styles. To open the Element Properties dialog box of a new legend and insert a new
legend simultaneously, please right-click on blank in the layout map window >
Insert > Legend. To open the Element Properties dialog box of an existing legend,
please double-click on the target legend.
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With the Element Properties dialog box, you can edit legend title, legend layers,
legend background and spacing configurations including title/items, columns, layers,
etc. The Background configuration enables users to change legend background by
clicking the background icon and selecting background style in Symbol Selector
dialog box. 

Export Map and Configure the Map Quality

After all the configuration of the layougt are accomplished, users can export the map
as map file. To do so, please click File > Export Map to open Export Map dialog box
to specify the file type, image resolution (pixel), file quality and format. 
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File Management

Sources of spatial information come from diverse aspects. This 

chapter apprise users of the categories of spatial data and how to 

utilize file management configuration within SuperGIS Desktop 10, 

so that users can manage their spatial data like raster data and 

vector data with ease.
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4 File Management

Sources of spatial information come from diverse aspects. This chapter apprise users

of the categories of spatial data and how to utilize file management configuration

within SuperGIS Desktop 10, so that users can manage their spatial data like raster

data and vector data with ease. 

· File Format
· SuperGIS DataManager
· SuperGIS DataConvertor

4.1 File Format

With Chapter Three, users know how to import spatial data, run attributes statistic
and draw a map. In addition to mapping, SuperGIS Desktop 10 provides more
functions, including editing, managing spatial data and employing spatial information
to analyze phenomenon.
 
GIS simplifies and sort spatial data as two models - raster data and vector data.
Raster data is the spatial data model defining space as arrays of equally sized cells.
Each cell stores attributes which are used to represent features with continuous data,

including surface elevation, rainfall distribution, and temperature distribution and so on.

Raster data is also employed to store substantial image file for it can effectively

diminish the data size.

 
Vector data represents geographic features in points, lines and polygons. Point data
are usually used to present distribution of unique features like buildings and animals.
Line data are often used to present linear features, such as rivers, roads and tubes,
etc. Polygon data are used to present a scope or an area. However, areas in different
scales will be presented with different features. For instance, cities are displayed as
points on world map while a single city is presented as a polygon on the city map.
 
SuperGIS Desktop 10 supports diverse raster and vector data formats:
 

Vector
Data

GEO, SHP, MIF, DXF, GML, DWG ,DGN.

Raster
Data

SGR MrSID GeoTIFF BMP GIF JPG JPG2000 ECW 
PNG LAN GIS

44
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4.2 SuperGIS DataManager

SuperGIS DataManager is capable of assisting users in managing spatial data files.
On SuperGIS Desktop 10, you can click Tools > SuperGIS DataManager to open
SuperGIS DataManager window. With SuperGIS Datamanager configuration window,
you can manage raster/vector data file and add new files. SuperGIS Desktop 10 now
also supports Feature Class and Personal Geodatabase.

Feature Class

Feature Class is a collection of geographic features, and each geographic feature is
comprised of geometries with the same type such points, lines and polygons. By
right-clicking on the folder icon > New > Feature Class, users can add a new layer in
point, line or polygon type. 

Personal Geodatabase

A geodatabase that collects point, line and polygon data. Files stored in one Personal
Geodatabase share the same coordinates and enable users to edit attributes with
ease.
 
To read more elaboration on how to manage files with SuperGIS DataManager, please
refer to the user guide attached within SuperGIS DataManager.

4.3 SuperGIS DataConvertor

On SuperGIS Desktop 10, users can click Tools > SuperGIS DataConvetor, or Start >
Programs > Supergeo > SuperGIS DataConvetor, to open SuperGIS DataConvetor
configuration window. With SuperGIS DataConvetor configuration window, users can
convert a specific vector data format into another format, or convert line features into
route data.
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NOTE: To read more elaboration on how to manage files with SuperGIS DataConvetor,
please refer to the user guide attached within SuperGIS DataConvetor.



 

 



5

Editing Functions

Editing functions supports users to draw a new map and modify features 

on map. Most  feature modification, including adding a new feature, 

panning, copying, pasting and deleting features and editing feature’s 

nodes and feature’s attributes, rely on editing functions. This chapter 

tells users how to edit features directly on map or by features’ attributes, 

and provides descriptions of editing functions usage and configuration 

tricks.
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5 Editing Functions

Editing functions supports users to draw a new map and modify features on map.
Most  feature modification, including adding a new feature, panning, copying, pasting
and deleting features and editing feature’s nodes and feature’s attributes, rely on
editing functions. This chapter tells users how to edit features directly on map or by
features’ attributes, and provides descriptions of editing functions usage and
configuration tricks.
 
· Overview of Editor Toolbar
· Edit Layer
· Edit Layer Attributes
 
 

5.1 Overview of Editor Toolbar

Follow steps below to start Editor: View > Toolbars > Editor.
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                                   Start Editor
 
 
Find the edior toolbar on the interface, tools’ functions are denoted below  
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5.2 Edit Layer

Edit Feature

Add A New Layer

To create and edit a new layer, please right-click on the group layer and select New
Feature Layer or add by SuperGIS DataManager. Users can refer to steps recorded
in section paragraph Feature Class within section SuperGIS Datamanger of
chapter File Management in SuperGIS Desktop 10 User Guide. And the feature layer
should be added into Data Content for subsequent editing steps.
 

                       Add New Feature Layer
 
 

Start Editing

Please notice that users can only select and query attributes of the selected features
before starting editing. To add a new feature, modify and edit features, you need to
start editing ahead of time. To start editing, please click View > Toolbars > Editor,

click  icon and choose the layer you intend to edit.
 

 Choose the layer you intend to edit feature on it.
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By utilizing  (Select Features), users can select a single or multiple feature(s) and
employ Cut, Copy, Paste, Delete functions within the Standard Toolbar to edit the
selected feature(s). Please notice that while using Copy and Paste functions to paste
a new feature, the pasted feature will be overlaid on the one you copy. Therefore, you
need to select and pan the pasted feature to the specific position by mouse cursor.
 

To save and stop the edits, please click the drop-down menu of  (start editing) >
Save Edits > Stop Editing.

 

 Start Editing, Stop Editing and Save Edits
 
 

Add New Feature

Users can add new features in point, line and polygon on layers according to the layer
type. Please notice that you can only add features whose type correspond with the
layer type. For example, points can be added on point layer only; lines can be added
on line layer only; and polygon can be added on polygon layer only.
 

To add a new feature in point, please employ (Sketch Tool) ahead of time and

see the mouse cursor changed into  graphic. Subsequently, click on the specified
position on the map to add new point features.
 
To add a new line feature, please utilize mouse cursor to click on map. The first
clicking is used to create the start node of a line while the second clicking is used to
create the end node. Users need to finish sketch to accomplish a new line feature. To
do so, please double-click on the end node of the new line feature, or right-click on the
end node and select Finish Sketch.
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                 To Finish Sketch
 
To create a polygon feature, you can repeat the step of clicking on map to create the
first node, vertices and the end node of the new feature, and double-click on the end
node to finish sketch. Besides, users can select a feature and right-click on the
feature to cut, copy, paste or delete the target feature through the drop-down menu.
 

 Select a feature and right-click on the feature to delete the target feature by the
drop-down menu. 
In addition to the basic steps of adding new features mentioned above, SuperGIS
Desktop 10 provides various tools like Midpoint Tool, Nearest Distance Tool,
Intersection Tool, Arc Tool and so forth. To know more elaborations on adding new
features, please refer to chapter Editing > section Editing Features > paragraph
Adding Features in SuperGIS Desktop 10 User Guide.

Edit Vertices

Each feature on map is comprised of a vertex or vertices  A point feature is a vertex;
a line feature must be comprised of two vertices at least; and a polygon feature
contains more than three vertices. To edit vertex/vertices of a feature, please employ 

 (Select Feature) to select the feature, click the drop-down menu within the Editor

Toolbar and select  (Modify Feature) tool to edit the target feature.
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 Employ different feature editing tool to edit features on map
 
 
Vertices of the feature will display on the screen after the target feature is selected.
You can keep on sketching the feature or employ editing tools to cut, mirror and
reshape the feature.
 

 A polygon and the vertices that are been editing
 
 
Move the cursor to the target vertex and right-click on the vertex to modify it. You can
inset, delete, offset and move the vertex, or modify properties of the vertex.
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 Edit a single vertex of a feature

5.3 Edit Layer Attributes

Attributes data, whose type contain text, value, and hyperlink and so forth, record
descriptive data of a feature, such as population, area and population density of a
county. By viewing attributes data, users can comprehend what features on map

denote. Besides, users can utilize tools within SuperGIS Desktop 10 to query, run

statistics of attribute data and even perform geoprocessing on spatial data. With

editing functions provided by SuperGIS Desktop 10, you can modify attributes by

employing Edit Attributes tool on editor toolbar or through attribute table of the

feature.

By Edit Attributes Tool

Users need to start editing to edit feature attributes. To edit a selected feature

attributes, please click to employ Edit Attributes tool and open the Edit Attribute
dialog box simultaneously. On the Edit Attribute dialog box, you can enter/modify
values in the attribute columns.
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             Edit attributes of a single feature
 
 

Through Attribute Table of A Feature

Users can also edit feature attributes through its attribute table. To do so, please start

editing and employ Select Features tool ( ) to select the target feature.
Subsequently, right-click on the layer of the selected feature and click Open Table to
open its attribute table. And you can see the attribute table witch is marked with text,
Editing, on its title.
 

                  The Attribute Table on Editing Mode
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On the attribute table of the layer, attribute column of the selected feature is shown
with yellow as its background color. You can click on the column to modify the feature
attribute in value or text.

             Edit Attribute in A Single Column
 
 

NOTE: In addition to basic editing functions mentioned above, SuperGIS Desktop 10
also provides various tools, including snapping configuration which is used to precisely
connect one feature to another, Split Tool, and Intersection Tool, etc. And SuperGIS
Desktop 10 Professional additionally provides users with Advanced Editor and
Topology Analyst to flexibly edit features and rectify error of spatial editing.
Furthermore, the COGO extension designed for civil engineer to digitalize results of
geodetic survey and the Land Parcel Editor for parcel surveyor are also available in
the latest SuperGIS Desktop 10.
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Analysis Tools and Extension

GIS is the system designed to help to visualize, edit and manage 

spatial data. The most important function of GIS is that it supports 

to analyze spatial data and enable users to solve problems. This 

chapter briefly introduces analysts and extensions within SuperGIS 

Desktop 10
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6 Analysis Tools and Extension

GIS is the system designed to help to visualize, edit and manage spatial data. The
most important function of GIS is that it supports to analyze spatial data and enable
users to solve problems. This chapter briefly introduces analysts and extensions
within SuperGIS Desktop 10.
 

6.1 Analysis Tools

Users can employ analysis tools through the drop-down menu within Tools on the
Standard Toolbar. SuperGIS Desktop 10 supports to add XY data through Excel table
and convert the added data into spatial coordinates, provides buffer analytic and
geoprocessing tool. Geoprocessing Tool enables users to process spatial data with
diverse operations, including Dissolve, Intersect, Merge and so on.
 

Add XY Data

SuperGIS Desktop supports users to apply XY data that are comprised of points’
coordinates in DBF and XLS. In this way, users can add points more easily.
 
Users can edit XY data through Excel and save the file in DBF or XLS. Nonetheless,
SuperGIS Desktop 10 only supports Excel 2003 and the previous version. Please
notice that you need to save the XY data in *.xls format.
 

          Edit XY data
 
 
As long as you have prepared the XY data file, you can click Tools > Add XY Data to
start Add XY Data dialog box.
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And configure XY data source, XY fields and coordinate system with Add XY Data
dialog box.
 

  

Buffer

Buffer, a zone surrounding a map feature with a particular distance, is also an
analysis tool used to analyze the proximity. Not only distance measurement tool,
Buffer analysis tool can be employed to help us know the buffer zone of a single
feature and the relationship between two buffer zones of two different map features.
For example, through Buffer analysis, we can know if two map features connect to
each other with particular condition, the appropriate distance between the building and
the river and the safe zonal area for a facility. The Buffer analysis tool provided by
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SuperGIS Desktop 10 supports users to draw buffer zone around any point, line or
polygon features on map, to analyze and to make plans. To operate Buffer analysis
tool, please click Tools > Buffer to open the buffer analysis configuration dialog box.
 

 A buffer drawn around a point feature         A buffer drawn around a line feature  

                  A buffer drawn around a polygon feature

 
 
NOTE: To know function elaboration of Buffer analysis tool, please refer to chapter
Analysis Tools > section Buffering in SuperGIS Desktop 10 User Guide.
  

Geoprocessing Tool

In GIS, spatial data are presented in point, line and polygon types, and features in
each type can be recorded in the corresponding layer only. Thus, GIS users need
geoprocessing tools to intersect, merge layers in different types with different feature
types, and set union of layers or clip a range on different layers. Besides,
Geoprocessing Tools can also help users to analyze and run statistics on spatial
data.
 
All the geoprocessing tools equipped within SuperGIS Desktop 10 can be employed
through Geoprocessing Tool dialog box. Five operations, including Dissolve, Merge,
Clip, Intersect and Union, are provided:

Operatio
n

Illustration Definition

Dissolve
The process of removing the boundaries that share
a single attribute value or removing the sharing
boundaries of adjacent polygons. Example: To
make villages and cities as one district in the
same county.
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Merge
The process of combining two layers that share
same boundary and are in the same data type.
Example: To combine counties and cities in the
south as a south district

Clip
The process of extracting a polygon overlaid on
the target layer. Example: To clip the polygon
based on the shape of an ecological area overlaid

on the layer of a county.

Intersect
The analytical operation used to select any
polygon feature that intersects with the target
feature. While running Intersect operation, the
range of the selected polygon

Union
The analytical process in which the features from
two or more map layers are combined into a
single, composite layer.

SuperGIS Desktop 10 provides various analytical extensions. To know more about

geoprocessing tools, please visit our website: http://www.supergeotek.com/.

6.2 Extensions

Graph

With statistical graphs, we can easily interpret some information, for example, the
comparison and contrast of the numeric data of related features. Thus, users can not
only recognize the changes of numbers but also figure out the trend of the
development. This chapter introduces how to create, manage and modify graphs.
 
To employ graph tools, please right-click on the toolbar of the map window in
SuperGIS Desktop 10 or click View > Toolbars, and select Graph.
 

http://www.supergeotek.com/
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Tools on Graph Toolbar

Graph tools include Create Graph,
Graph Manager and Load Graph.

Create Graph

SuperGIS Desktop 10 provides 6 graph types, including Vertical/Horizontal Bar,
Vertical/Horizontal line, Vertical Area, Scatter Plot, Box Plot and Pie chart. To create

and configure a new graph, please click  (Create Graph) icon to open the
configuration dialog in which you need to select graph type, XY fields’ name. To create
a composite graph or overlay graph, please employ New Series function to do so.
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                                           Create Graph dialog box
 
 

Graph Manager

Users can manage the existing graphs through Graph Manager. Please click 
(Graph Manager) icon to edit the target graph with Graph Manager dialog box, or click 

(Create Graph) icon in the dialog box to create a new graph.
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Modify Graph Appearance

SuperGIS Desktop 10 Graph tools enable users to configure graph appearance. To do
so, please right-click on the graph and click Properties…  to open graph appearance
configuration dialog box.
 

 Right-click on the graph and select Properties…  within the drop-down menu 
SuperGIS Desktop Graph tools enable uses to configure the graph appearance,
including title color, background, legend, font, axis, axis style, grid, etc. As a result,
users can create their own graph. You can set the appearance while you are creating
a graph. Also, you can adjust the appearance after the graph is created.
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             Tab for configuring graph appearance 
 

Feature Guided Pages

SuperGIS Desktop 10 provides you the feature guided pages tool, which helps you to
publish and print your own atlas. It views each feature as a single map page and is
especially useful when publishing thematic maps because the map readers can see a
local and detailed information of each feature.

Feature Guided Pages Toolbar

Configure Feature Guided Pages

Before using the feature guided pages tool, you may want to switch to the layout view
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first (View > Layout View). To open the tool, right-click anywhere on the toolbar and
select Feature Guided Pages. Then the Feature Guided Pages tool should appear.
The figure below is an overview of the tool. To set the feature guided pages, click on

the setup icon ( ).

After clicking on the setup icon ( ), you can then enable the feature guided pages in
the General tab of the Feature Guided Pages Setup window. Here you can setup the
map layer and its name field you want to use. The name field will be the title of the
map. The page number can also be set here. You can set its starting number or you
can choose an attribute field to be the page number field.

 
 

Browse Pages

You can browse each page in the layout view after activating the feature gzuided

pages (View > Layout View). To refresh maps, just click the Refresh icon ( ). To

browse different pages, you can click on First Page icon ( ) or Last Page icon ( )

to move to the first or last page, or you can use Previous Page ( ) or Next Page (

) to move to previous or next page. The page name (or page number, depending on
your choice) will be shown in the box. If you want to directly go to a certain page, for
example, page 8, you have to select Show Page first, and then enter 8 into the box
(You can also enter the page name if you select Show Name).
 

               Configuration for showing name or page number
 
 

Design Map Page

SuperGIS Desktop 10 provides you some tools to design your own map page,
including insert page name, number or other customized contents. To insert page
name, click Insert Text>Page Name, then the feature’s name will be shown on the
map page. To insert page number, you can click Insert Text > Page Number or
Insert Text > Page Number with Count.
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Configure Page Print Setting

After finishing your map page design, you are ready to print the map. Please notice

that you need to stwich to layout view to print the map. Click Print icon ( ), you can
select to print all pages or the current page, or specify page range to print.

 

  

Georeferencing Toolbar

Georeferencing technology is one of the crucial elements in GIS. Precise image
position is helpful for users to interpret terrain changes. The Georeferencing tool
provided within SuperGIS Desktop 10 enables users to contrast the image with the
specific features to configure the accurate coordinates for the image. For instance, the
aerial photographs can be located over an existing map to reference the real locations
of buildings or roads on the aerial photographs. To employ georeferencing tool, please
click View > Toolbars > Georeferencing.
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                    To use georeferencing tool

Georeferencing Toolbar

Georeferencing tool supports users to rotate and update images. Before transforming
or georeferencing the image, you can configure to update the image automatically or
manually. To update the image manually, cancel the tick by Auto Adjust.
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Transformation

Including image rotation, shifting and scaling, Transformation enables users to adjust

the image data to a correct angle to review. To do so, employ Rotate tool ( ), Shift

tool ( ) and Scale tool ( ).

Image Rectification

The system can rectify image to correct position by use of control points. Map
rectification takes at least four control points and the four of them should be evenly
distributed to the four corners of the map. Generally speaking, the more control points
lead to a more accurate result, but it is also possible that a poor rectification result is
obtained due to too many control points.

Adding Control Points

To add control points, please select the image you want to georeference on the

Georeferencing toolbar and click Add Control Points tool ( ). Then click on the map
to add green target point and click again to add red control points. If Auto Adjust is
checked, the display will be instantaneously updated and the target point will be
shifting approaching the control points; if not checked, the image remains but the
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target points and control points can still be seen, and a blue line connecting target
points of the same group and control points will show.

Management of Control Points

Users can use the Control Point List tool ( ) to manage all the control points,

including delete existing control points, save all the control points, or load control

points. The information related to the control points are shown in the control point list,

including its source coordinates, map coordinates, and residual. These information

can help to evaluate the accuracy of the geo-referencing. 

 

Starting to Rectify

According to the number of control points, you can select different types of
transformation polynomial. Three types of polynomial are provided in SuperGIS
Desktop 10, 1st Order Polynomial can be applied whenever control points are added;
2nd Order Polynomial can be applied as the number of control points is 6 and over;
3rd Order Polynomial can be applied as the number of control points is 10 and over.
The different Polynomial can be applied to reduce the residual between target point
and control point to enhance the precision. Select different polynomials by clicking 
Georeferencing > Trasformation. After control points and polynomial are confirmed,
please click Georeferencing > Rectify to start to rectify.
 
 
NOTE: To know more about georeferencing tools, please refer to chapter
Georeferencing Tool in SuperGIS Desktop 10 User Guide. Besides, SuperGIS Data
Rectifier within SuperGIS Desktop 10, provides users with more tools to rectify
images. To employ SuperGIS DataRectifier, click Tools > SuperGIS DataRectifier. 
 

Land Parcel Editor

The land parcel editor is a land administration tool which helps to manage your parcel
data such as adding, deleting, and editing. The parcel data can provide important
parcel information for commercial and residential buildings. It is important to updating
and managing the parcel data to keep up the dynamic developments of the city.
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                    To Use Land Parcel Editor
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Land Parcel Editor Toolbar

 
 

Open/Import/Create Parcel Data

To use the land parcel editor tool, you have to add the parcel data to the SuperGIS
Desktop first by opening existing parcel data, importing existing personal
geodatabase (.mdb file) and map layers, or creating a new parcel data.
 

 
 
Once you add the parcel data, a parcel fabric will be added as a group of layer to
SuperGIS Desktop, including the sublayers such as Control Points, Line Points,
Points, Lines, and Parcels. The parcel fabric group layer is similar to a regular group
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layer in SuperGIS Desktop, yet layers cannot be added to, or remove from, the parcel
fabric group layer.
 

 

Edit Parcel Data

Click Start Edit within the drop-down menu of Land Parcel Editor to edit parcel data.
 

 
 

 Add Parcel Features

You can add a new parcel polygon or line (arc) feature. To add a parcel polygon, click

on Create Parcel Features ( ). Then click on the map to add nodes and draw the
boarder of the polygon. 
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 Manage Parcel Features

To manage parcel features, you can use the tools provide by SuperGIS Desktop 10,
including Merge Point, Enlarge Feature, and Move Parcel Features. Before managing
any parcel features, you have to select a target feature using Select Features tool (

) first. The Parcel Details window will show the details of the selected parcel
feature (the Parcel Detail window can be opened manually by click Parcel Detail
icon). 
 

 Edit Parcel Details

To edit the parcel detail, you can first select a target parcel feature and switch to the
Parcel Detail tab. Here you can edit its properties (attributes) in the Property tab, and
also the properties of its edges.
 

 To edit parcel properties (attributes) through Parcel Detail tab

To know more elaborations of Land Parcel Editor function, please refer to chapter
Land Parcel Editor in SuperGIS Desktop 10 User Guide.

COGO

The COGO tool is the short for coordinate geometry, which is useful for creating
human-made features, including roads, land parcels, and so on. Before creating those
features, you need a record from civil engineers which contains the results describing
the measurements of features, which are the coordinate geometry descriptions. For
example, a straight line has its direction and distance, and a curved line has a radius,
angle, arc length, direction etc. Users can use the COGO tool to precisely create
those features in SuperGIS Desktop.
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COGO Toolbar

Create COGO lines

The COGO tool provides users different ways to create new COGO lines, including
Traverse, 2-Point Line, Offset Line, Cul-De-Sac, and Split Line Proportionally. To use
the COGO tool, users should have at least one line layer added to the SuperGIS
Desktop and enable the edit mode with the line layer as the target layer.

If the survey measurements collected from the field are in the form of directions and
distances, angles and distances, or curves, they are called traverse. Click the

Traverse icon ( ) to open Traverse window, which shows the segment list of the new
line feature.
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Users can assign the start/end vertex of the new line feature by typing into its X,Y

coordinates or clicking to click on the map. And then click  to add a line
segment. The traverse tool allows users to add straight lines or curves by using
Direction-Distance, Angle-Distance, Curve, and Tangent Curve ways. 
 
COGO also supports tools like Offset Line, Cal-De-Sac, Split Line Proportionally,
Create COGO lines using existing line features, etc. To know more elaborations of
COGO tools, please refer to COGO > Create COGO Lines in SuperGIS Desktop 10
User Guide.
  

Get COGO information

Sometimes users may want to get some COGO information from SuperGIS Desktop,
they can use the COGO tool. For example, they know the angle and the chord of a
curve, and they want to know other measurements of the curve to help them create a
new curve feature. They can use the Curve Calculator to get the necessary
information. Other tools include Ground to Grid Correction, Report, and Area
Calculator.
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 Ground to Grid Conversion

The survey data, including the directions and distances of line features, are measured
on the surface of the Earth, which are called ground measurements. But the directions
and distances of the line features in SuperGIS Desktop are projected data, which are
called grid measurements. The two measurements are often different and need to be
converted. Users can use the Ground To Grid Conversion tool to convert the data.

Click  to open Ground To Grid Conversion window, and enter the direction offset and
distance factor to correct the data.
 
NOTE: If you don't know the two parameters, you can also use interactive ways to
provide the information. One interactive way is to enter the direction and distance
measured on the surface, and then click on the map to show the corresponding line
on the map. The other interaction way is to click on the map to provide both the
direction and distance measurements of the ground measurement and grid
measurement.
 

 Report

The Report tool help users to get the correction information according to the
parameters set in the Ground to Grid Conversion window or measure the angle. With

Report ( ), you can report results of line measurement, angle, orthogonal distance,
area and perimeter and coordinates.

 Area Calculator

The Area Calculator calculates the area of the selected COGO lines. To use this tool,

users should first select COGO lines that form a closed polygon and click . The
information includes: Number of lines, Grid Area and Perimeter, Ground Area and
Perimeter, Attribute Length, Misclosure As Direction/Distance, Relative Error Ratio,
Adjustment Method, Attribute Ground Area and Perimeter and Attribute Grid Area and
Perimeter.
 

 Curve Calculator

The Curve Calculator helps users to get the curve measurements. Users only have to
provide 2 of the curve measurement, such as angle and chord, to get all the other
curve measurements, including angle, radius, arc length, chord distance, chord
height, and tangent length.
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Update Attributes

Update attributes will calculate the coordinate geometry descriptions for the selected
COGO lines. For straight lines, you will get the distance and direction measurements
of them in the attribute table. And for curved lines, you will get the chord, angle,
radius, chord direction, arc length, and so on in the attribute table. The units are the
same as the map unit. To get the information, you should add the corresponding field
name to the table. For example, to get the distance of the straight line, you should
add the 'distance' field to the table. The table below lists and describes the required
table fields to maintain COGO attributes.

NOTE: To know more COGO manipulations, refer to chapter COGO within SuperGIS
Desktop 10 User Guide.

OGC

OGC (Open GIS Consortium) is a voluntary, non-government and non-profit
organization, devoted in developing an open system to run geoprocessing and leading
the interoperability standard of geographic information.
 
WMS, WFS, WCS and WMTS data are provided in “OGC Service” of SuperGIS
Desktop 10:
 

WMS Web Map
Service

The standard protocol defined by OGC for internet client end
to demand the mapping

WFS Web Feature
Service

The standard protocol defined by OGC. Client end sends the
request of the features needed by the application through
WFS to obtain the data.

WCS Web
Coverage
Service

The standard protocol defined by OGC for client end to
obtain the image data of specified spatial area and band,
such as satellite image and remote sensing image, etc.

WMTS Web Map
Tile Service

Also map cache. While the front-end requires the map
imagery of a specific region, the server will transmit the map
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tile of that region to display on the front-end.

 
To open OGC service, right-click by toolbar of SuperGIS Desktop 10 and select OGC
Service, or click View > Toolbars > OGC Service.
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 OGC Service Toolbar

Add OGC Service

To add a layer, please select the service type and click Add Service:

“ URL” field is used to be input service address. “Code Page” field has its default
setting as “UTF-8”. Click OK, you can see the service address you input appears in
the field of URL.

Click  to get open service.
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Cache Generator

Cache Generator quickly creates cached map in STC format. In this chapter we are
going to explain each setting. Starts SuperGIS Desktop, add the layers that you want
the cached map to include to SuperGIS Desktop. Right-click on blank part of toolbar
to show the menu and click Cache Generator. Or click View > Toolbars > Cache
Generator to open its toolbar.

 
          To open Cache Generator through View
 

Cache Setting

Click Cache Generator button to show Cache Setting window. In Scale Definition,
enter the required scale for the cached map, you can enter directly or press Suggest
button to quickly create.
 

 Cache Generator
 
In Extent, the extent boundary values of the current layers will be accessed by default
and displayed here. You can also enter scales in Scale Definition and add by click
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Add button, or adjust the map extent first and navigate to this page and click Current
 Extent to capture the current extent values.
 

 
Image Setting sets up the file format of cached map, image quality, width, height and
smoothing. Click OK as all settings are finished.
 
Cache Generator window shows up sequentially, here check the scales to proceed
and layers to cached with, set up the storage path for the generated STC cached
map, and set the background color and Size of Basic Section. At last click Start
Generating Cache button and the system will start to generate cached map. As the
cached map is completed, a message shows up asking do you want to add the layer
to the current map, if you click OK, the STC will be added to the map.
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GPS

GPS(Global Positioning System) is a set of global navigation satellite system, used
with appropriate receiver can precisely decide any position on the surface. The
satellite net is owned by US Department of Defense, which can be used in fields of
navigation, mapping and survey, in which takes precise orientation.
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GPS Toolbar
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GPS Settings

Open "GPS" toolbar, click "GPS Settings" on "GPS" drop-down menu. "GPS

Settings" dialog box shows up.

 
Select "Connect to GPS receiver" or "Simulate GPS using point or line layer." You
can only select one item from the two. While one item has been selected, the other
item turns non-performable status. If you select "Connect to GPS receiver" please
select the communication port to connect to GPS in "Communication Port." When
you first open the tool, the item only lists the built-in communication ports. Besides
you can select "Auto Detect", system will automatically link to various built-in effective
communication ports.
  

Tracklog Settings

When SuperGIS Desktop receives the signals, the current GPS status will be
demonstrated on the window. To create a new Tracklog file, please click GPS >
Tracklog Settings > New…
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You can configure file path and feature type to output, and open the traklog file you
recorded. 

 
When you accomplish all the configurations, click OK and go back to Tracklog
Settings configuration dialog box, and click OK for accomplishment.

NOTE:
 

Only basic steps of tracklog settings are portrayed in this paragraph. To know
more elaborations, please refer to  chapter GPS Add-on within SuperGIS
Desktop 10 User Guide.
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GPS Connect to GPS

When configurations are accomplished, you can check Connect to GPS receiver in
GPS Settings dialog box. Click Auto Detect, and system will connect to effective
communication port automatically. You may modify the other settings if you have
particular demand; otherwise, we suggest to keep the four items with default values.

Subsequently, click Open GPS Connection  on GPS Toolbar to SuperGIS
Desktop 10 to GPS.
 
GPS Add-on within SuperGIS Desktop 10 provides diverse functions, including GPS
connections, content displaying, tracklog updating, etc. To know more elaborations,
please refer to chapter GPS Add-on in SuperGIS Desktop 10 User Guide.
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Process Design

Overview of SuperGIS Toolkit

SuperGIS Toolkit is a powerful Process Design program, through which a Process
Design can be designed to handle the various analyses or processing.
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 Open SuperGIS Toolkit Toolbar
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 SuperGIS Toolkit Toolbar

Create a New SGD Project

Click SuperGIS Toolkit button to open SuperGIS Toolkit window. And right-click on

SuperGIS Toolkit to select New Toolkit ( ).
 

 
 
Right-click on the newly added New Toolkit to select New > Process to build a new
process.
 

Right-click on the newly added New Process and select Design to open Process
Designer window.
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The default Processing items provided by SuperGIS Toolkit can be dragged into
Process Designer window directly to build process.
 

 
 
To open process setting window, you can double-click on the newly-added process
items or right-click the process item, and select Open on Process Designer window.
In the processing window, users can set field contents and parameters.



SuperGIS Desktop Quick Start Help

92

 

When the first process is accomplished, you can drag other functions into the existing

process and utilize Add Connection tool ( ) to yield the first process for second
process using.

When process parameter settings are configured, please right click on any vertex of
output polygon feature and select Process Result to output the process result to the
front-end website. Results that are set as process results show with R on the upper-
right of the vertex.
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                     Configure Process Result
 
 

And you can click Run icon ( ) within Process Designer dialog box to accomplish
your design.

To publish a particular map service of Geo-processing through SuperGIS Server,
please click the Save icon on Process Designer toolbar to accomplish the process
designing task and save the map as SGD project.
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