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1 Welcome to Use SuperSurv

1.1 Browsing Map

At the lower-left bottom of the map, there is a map tool bar that helps you to browse the

map with different tools with ease. Map Tool includes Zoom in , Zoom out ,

and Full extent . Users can adjust the extent they need. Also, users can zoom in
the map with 2 fingers or tap the map twice to zoom in the map. Or you can tap the
North arrow to show electronic compass so that it is easier for you to identify the
correct aspect and angle in the real world environment.

    

1.2 Pan to

The system provides 3 ways to position, including Pan to GPS, Pan to feature and Pan
to waypoint. Users can choose the way of positioning they need according to their
situation.
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1.3 Editing

You can create a new layer and edit spatial data in SuperSurv.
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1.4 Layer Management

With Layer Management, you can add a layer to the map and set the properties of the
layer. If you create a new layer, you can customize tables to enter the attribute data
rapidly.
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1.5 Waypoint

You can set and manage waypoints and pan to the waypoint. Besides, you can display
the waypoint information on the map to help reaching destination. Or you can use AR
(Augmented Reality) to help find the correct direction and distance to the destination.   
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1.6 GPS Track

After turning on GPS, you can record GPS track and save the point data as KML file,
line data as SHP file. In addition, you can also display the track on the map that helps
to know the route you move.
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1.7 Data Query

The system provides 2 ways to query: attribute query and identify query. Attribute query
allows users to enter the attribute conditions, and the system will display the features
that meet the conditions on the map. If you use identify query tool, you can tap the
feature on the map, the data in the specified field will be displayed.  
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1.8 Measure Tools

Measure tools enable you to measure distance and area on the map. Users can draw a
line segment to measure distance and a polygon to measure area. Even the features
can be measured. The measure tools can be used in any conditions. 
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1.9 Online Editing Feature Service

Feature Services published by SuperGIS Server can be displayed on SuperSurv and
those editable services can be edited with features and attributes. Furthermore, the
editing can be synchronized to SuperGIS Server. In addition, Feature Service attributes
can be queried and be measured just like the ordinary layers. 
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2 Installing and Licensing

2.1 Download Related Applications to Mobile Device

To install SuperSurv, you need to use installation CD to install SuperSurv in PC. Then,
copy the installation file (SuperSurv.apk) from PC to mobile device. 

Since there is no built-in Windows-explorer-like application in Android mobile device for
users to browses files, it is suggested that you download the related file explorer
application from Android Play Store, such as ES File Explorer and install it. Therefore,
it would help you browse the files easily. Besides browsing installation file, the file
explorer App enables users to browse any other files saved in the mobile device.

    

2.2 Installation

The procedure of installing SuperSurv is to install SuperSurv from CD to PC, connect
PC with mobile device, and copy the installation file to mobile device to install. 
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1. Insert CD to CD-Rom drive and the installation window appears. If the window does
not appear, please double click CD-Rom drive, and click Install SuperSurv 3.3.

    

2. As InstallShield Wizard appears, click “Next.”
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3. Select “I accept the terms of the license agreement” and click “Next.”

    

4. “Ready to install the program” appears, click “Install.”
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5. As the installation is completed, click “Finish.”
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6. Click Start > Programs > SuperGeo > SuperSurv 3 > Install SuperSurv. 

    

7. In the folder of Install SuperSurv, please copy “SuperSurv.apk.”
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8. Connect mobile device with PC, and set the connection type as Disk Drive.

    

9. Paste “SuperSurv.apk” to the directory of mobile device.
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10.Set the connection type other than “Disk Drive”, and start to install SuperSurv.apk.  

11.Tap SuperSurv.apk.

12.Tap Installation.  

    

13.As the installation is completed, tap “Done.”
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2.3 Licensing

1. If you have not got the license, the screen will show the message below as you start
SuperSurv. If you have purchased SuperSurv, you can tap License to enter the serial
number. If it is a trial version, please tap Trial, and you will have 10-minute trial.  
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2. Please Enter the serial number and tap OK. As the application is licensed
successfully, it will start SuperSurv automatically. 
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3 Quick Tutorials

3.1 Quick Start Guide

The Quick Start Guide will be shown while you start SuperSurv, illustrating commonly
used functions with simple texts and pictures step by step. You can also turn off this

function by uncheck the Show the quick guide on startup option. Tapping  will
lead you to the main map on SuperSurv.

     

    

You can switch between quick guide pages by sliding the screen. Tap the Close
button will close the topic.
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3.2 Creating a New Project

SuperSurv  works  with  a  project  environment.  All  the  layers,  track  files,  photos
generated  by  SuperSurv are  saved  in  a  project  environment,  while  all  the  settings  of
projects are saved in SPP project  file.  When you start  SuperSurv for the first  time,  the
system will  ask  whether  to  create  a  project  file.  If  SuperSurv has  been  used,  as  the
system starts, you can tap Menu on the mobile device > Create a new project  to build
a  new project  environment.  To  create  a  project  with  Online  Map  Tool  please  refer  to
Online Map Tool Project.

        

    
To create a new project,  you need to name the  project  and  set  the  spatial  reference.
What  should be noted is  that  project  name  and  spatial  reference  cannot  be  modified
after being set. Tap “Please select” to set spatial reference.

The  coordinate  systems  provided  by  spatial  reference  include  geographic  coordinate
systems  and  projected  coordinate  systems.  In  addition,  users  can  also  build
customized  coordinate  system  by  importing  PRJ file.  Please  choose  the  coordinate
system you need and click OK.
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As the project is created successfully, the system shows up. 
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SuperSurv supports  to use GIS vector layers,  including GEO and SHP file format.  The
way to create a new layer,  please refer to Creating a  New  Layer.  Besides,  you  can
add a SGT basemap or a STC basemap to enrich the map.  The way to generate STC
basemap please refer to SuperGIS Desktop or SuperGIS Server User Guide.  About  the
way to add the two kinds of  base  maps,  please  refer  to  Adding  SGT  Base  Map  or
STC Base Map. 

As  you  build  a  project  environment  successfully,  a  folder,  SuperSurv,  will  be  built
directly in sdcard. The folder contains  a folder named after the project  to save the files
related to the project  and a Template folder.  For example,  the project  name is  “project
1”, and the project folder is named after the project. 

The project folder includes the subfolders: 
Layer: All the layers created in the project are saved in the folder. To add the existing
layers to use in SuperSurv, you can copy the layers (SHP/GEO) to Layer folder. Then,
start SuperSurv, tap Manager Layer > Add Layer, you can therefore add the layer to
map by checking it. 
Photo: Photos taken with SuperSurv are saved in the folder
Track: All the track files recorded with SuperSurv are saved in the folder
Waypoint: Waypoint files exported from SuperSurv are saved in the folder
SPP file: SPP project file 

Therefore, every time you create a new project, SuperSurv folder will create the folder
and subfolders. 
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3.3 Online Map Tool Project

To create a project with Online Map, like OpenStreetMap, as base map please follow
the steps below.

Choose Online Map Tool Project on creating a new project.

    

Enter the project name, the Spatial Reference is grayed out. 
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Tap the Map Type and choose a online  map on the menu to be your project's base
map. Click OK.

    

Return to the map and Online Map displays.
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The internet connection of the device must be confirmed available before creating a
project with Online Map Tool so that users can access the online map. 

3.4 Open a Project

As you close SuperSurv,  the system will  save the project  environment  in  SPP  project
file.  Next  time you start  SuperSurv,  the  system  will  read  the  settings  of  the  previous
project  as  default  display.  If  you  would  like  to  open  other  projects,  please  tap  Menu
function on the mobile device and choose open project to open another project. 

    

3.5 Adding SGT Base Map or STC Base Map

In addition to adding GIS layers, you can add SGT base map or STC base map to
make the map more complete and abundant. Tap Menu button on the mobile device>
Settings/View > Set base map and choose the SGT project file or STC project file.
Then tap Ok. 
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Note: STC map includes 2 files, .stc and .stp; both of the files should be copied to
your mobile device. While selecting the basemap, please select *.stp file.

Back to Settings/View, and tap Back key, and tap Yes in the dialog. 
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Back to the map,  the SGT basemap or STC basemap is  added to the map.  A project
file can contain one SGT basemap or one STC basemap only. 

       

The way to create STC project file, please refer to SuperGIS Desktop or SuperGIS
Server User Guide.



Quick Tutorials

36

3.6 Switching Online Map

A variety of online maps are provided  with Online Map Tool and users are free to
change online map on SuperSurv at any time.

Tap Layers > Settings. Tap Online Map to enter the layer setting page.

    
 

Tap Map Type and select the online map to use and tap OK. 
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The map is changed to new one.
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3.7 Browsing Map

At the lower-left bottom of the map, there is a map tool bar that helps you to browse the

map with different tools with ease. Map Tool includes Zoom in , Zoom out ,

and Full extent . Users can adjust the extent they need. Or you can tap north
arrow to show electronic compass so that it is easier for you to identify the aspect and
angle of the environment.
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3.8 GPS Positioning

To display the current GPS position on the map, please tap  on the upper-right

corner to pan to the current GPS position. Then, a purple mark  will be displayed
on the map. The fan-shaped area is the visual angle. The longitude and latitude
information will be displayed on the top of the map; tapping the information can convert

to project coordinate system. Tapping  can hide the position information bar;

tapping  can expand the bar. 
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3.9 Creating a New Layer

If you have no available layers, please create a new layer. Tap Survey > Create Layer.

 
In the setting  page,  please  enter  the  layer  file  name,  layer  name,  select  code  page,
layer type (point, line, polygon) and choose the file format  (SHP or GEO).  After setting
is finished, tap OK.  
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Field setting dialog appears, choose Start to Customize Table, and tap OK. 

In “Create a New Layer”, set the field name and field properties. You can tap a field to
set the field format in Field Setting. 
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To create a new field, please tap , “Create a new field” appears. Please select a field
type and set the format. About the details of the field type and format, please refer to 
Custom Table.
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After the setting is finished, please tap OK and back to the map. Survey toolbar shows

up on the top of the map. You can tap  to display the complete survey toolbar. 
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Then, Add Vertex Manually  is enabled. According to the layer type (point, line,
polygon), you can tap the map to create new features. 

    

After a feature is created, if you would like to enter attribute data, you can tap Feature

Selection Tool , tap the feature whose attributes you would like to enter. 
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Then tap Edit Attribute , and you can edit the attribute data in Enter Attributes
page. 

    

Also, you can edit the attributes right
after a feature is created. Please tap

Survey Setting , and set “Input
attributes after creating a feature” as On
and tap OK. Back to the map, you can
see Enter Attributes page right after a
feature is created.
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3.10 Adding Layers

As  you  have  created  multiple  layers,  you  can  apply  Add  Layer  function  to  add  the
specified layers  to the map.  The layers  that  are not  chosen will  not  be display  on  the
map. Tap “Layers” > “Add Layer”, and all the layers  are listed here.  You can select  the
layer you want  to add,  and tap OK. Back to the map,  the  map  displays  the  selected
layers. 

   

How to add the existing layers to SuperSurv map? To add existing layers to use in
SuperSurv please copy the existing layers to Layer folder of SuperSurv folder, start
SuperSurv, so that the Add Layer list will include the added layers. Check the layers to
display and you can see them displayed on the map. 
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3.11 Editing Layers

To Edit Layer, you need to specify the layer you want to edit. Tap “Survey” > “Edit
Layer.”

In Please Select Editable page, select
the layer you would like to edit. Then
tap OK. 
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The editable SuperGIS Server Feature Service will be listed as editable layer, when
such layer is selected, all the layers contained by this Feature Service will be listed as
editable SuperGIS Server layers. The way to edit SuperGIS Server layer is the same as
to edit ordinary layers.

    

Please note that you can only edit a layer each time and you cannot edit multiple
layers at the same time. To edit another layer, you need to switch another layer. Back

to map, Survey toolbar shows up at the top of the map. You can tap  to expand the

complete survey toolbar. In addition to Add Vertex Manually  to add new features
on the map, you can edit the existing features. You need to select the feature first and

then edit the feature. Tap Feature Selection Tool , select the feature you want to
edit. 
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As a feature is selected, you can use the following buttons: 

Delete Feature 
Delete the selected feature. 

Move Feature 
Move  the  selected  feature,  vertex,  stretch  feature,  rotate
feature, insert vertex, and delete vertex. 

Edit Attribute Edit the attribute of the selected feature. 

Pan to Feature 
Pan to the specified feature. 

Survey  toolbar  setting

5 items to set: 

a. Input attributes after creating a feature: 
Whether to show up attribute window right after a
feature is create. ON is Yes, OFF is Not. 

b. Sampling time for collecting a GPS position: 
Set the sampling time for collecting GPS
positions. The longer the time bar is, the longer
time it takes. 

c. Interval for continuously collecting GPS
positions: Set the Interval for continuously
collecting GPS positions (line layer/ polygon layer)
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d. Outline color when editing feature: Set the
outline color when editing feature.

e. Snap to vertex when editing features: Set up
the snapping tolerance for vertex editing, the unit is
pixel. 

Switch editable layer 

 
Stop the current editing and switch another layer to edit. 

You can stop the current editing by 2 methods: 1. long-press  2. press Back key,
and a dialog will appear to check whether you would like to finish the editing. Tap OK to
finish editing. The details of editing, please refer to Survey. 

A message will show up to confirm whether users want to synchronize data to Server
upon the editing is finished. Please tap Yes if you want to synchronize the data,
otherwise, tap No.

3.12 Importing Waypoints

If you have known the route of field survey and there are several locations you must
pass by, you can edit the coordinates of the locations on PC and then import the
locations to SuperSurv. In field survey, you can apply waypoint to know the relative
location between current position and the locations you must pass. The system
supports to import TXT, CSV or KML.

Besides, if you want to display some more information on the map, such as rain gauge
station, hospitals, scenic spots, etc. you can apply notepad to create the coordinate
data. Then, the text file can be imported to the system. The coordinate data can be
displayed as points on the map and help you know the positions of the points
effectively. 

The following is the way to create TXT file to import waypoints.
1. Connect your PC with the mobile device. 

2. Start notepad on PC, and enter waypoint name, X coordinate, Y coordinate, and Z
coordinate. 

3. After entering, please save the file. Then copy the file to your mobile device. 
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Note:
While editing waypoint information in notepad, enter Name, X, Y, Z in the first row.
Then, enter the information of each point in each row.
Name, X, Y, and Z stand for waypoint name, X coordinate of waypoint, Y coordinate
of waypoint, elevation of waypoint.
The supported coordinate systems are WGS84, TWD67, and TWD97. if you use
WGS84, the system only supports “degree.”

       
4. In SuperSurv, tap Waypoint > Manage. 
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5. In Waypoint management window, tap import. 

    

6. Select the file you created in Step 2, and tap OK. 
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7. Back to waypoint management window, tap Back key, and the message appears.
Tap Yes. 

    

8. Back to the map, and you can see the imported waypoints. The icon on the map
stands for the position of waypoint. The waypoint name is disaplyed above the icon. 
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3.13 Adding Waypoints

In field survey,  you might  need  to  add  some  points  to  survey  temporarily  because  of
accidents or missions. Then, you can create new waypoints  to complete the operation.
Or  when  you  are  surveying,  you  might  need  to  add  some  point  information  (e.g.
building, tree, etc.) for references, you also can apply waypoints to achieve the target. 

1 Long-press the position you would like to

add a waypoint, the icon  will show up.
Please tap it. 

2 “Add waypoint” window shows up, please
select the coordinate system, and enter
waypoint name. The coordinate fields
(longitude, latitude, elevation) shows the
current coordinates. You can modify the
coordinate values manually. Please tap OK
to finish.
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3. Waypoint is successfully added. The name of waypoint is also displayed on the
map. 

    

Note:
The function can be worked with Positioning function to rapidly zoom to the target
position and add the new waypoint by long-pressing.
You can also use waypoints as an annotation of points on the map.
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3.14 Exporting Waypoints

Surveying with SuperSurv in  the  field,  you  can  work  with  waypoint,  and  the  waypoint
can be used as  an  annotation  of  position  (please  refer  to  Adding  Waypoints).  After
surveying, you can export the waypoints to export the points to check and display them
on different platforms. 

1. Tap Waypoint > Manage. 

2. In Waypoint management window, the
waypoints will be listed on the left, and
Export is on the right. You can export all
the waypoints as files. 
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3. Enter the file name and choose the file format to export. There are 3 formats, KML,
TXT, CSV. After setting, please tap OK.

    

4. The waypoint is exported successfully. The
message will show up and display the
path.

Note:
Waypoints can be exported and saved as TXT, CSV, KML formats. You can upload the
data to PC, other applications, or on Google Earth.
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3.15 Track

You can apply track to record the path you pass in the field ; the track can be used for
further application or guidance. 

1. Tap Track > Record. The track toolbar will show up on the right. Tap  to start
recording. The upper-left corner will show the Recording. 

    

2. Start recording, the track toolbar will show 2 options. You can tap   to pause to

record, and then the upper-left corner will show the message .

Tapping  can continue to record. You can tap Pause to record and start
recording for more than once. During the process, the track will be saved in the same
track file. 
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3. As you would like to stop recording, please tap  to stop recording. The upper-left

corner shows the message . Then, the track file will be saved
directly. The file will be saved in Track folder in the project folder. 

Note:
Track recording only works when GPS positioning works successfully.
The name of track file isYYYYMMDD_XX; YYYY is year, MM is month, DD is day,
XX is the order of the file created on the same date, for example “20110328_02” is the

second file generated on March 28th in 2011.
Files are saved in point layer (*.kml) and line layer (*.shp) in Track folder in the
project folder.
If you did not close the system in a normal procedure, the current track will be saved.

3.16 Query

The system provides 2 methods to query: attribute query and identify query. 

1. Firstly, you need to set the query conditions, tap Query, and the query toolbar will
show up on the left. 
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2. Tap  and enter query condition window. Tap settings below Attribute Query and
Identify Query to set the settings. Attribute Query only allows users to query a single
layer; Identify Query allows users to query multiple layers, you can select all layers
by checking “Select All.” 
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3. After setting the layers, the layer you set to query will be displayed below Setting.
Then, you can set the fields you would like to query of each layer. Both Attribute
query and Identify query are able to set to query multiple fields or you can check
“Select All” to select all fields. Attribute Query and Identify Query both allows users
to set multiple fields. After setting, please tap OK. Then, back to Set Query
Conditions page, the fields you set to query will be listed here as well. 

    

4. As the setting is finished, please tap Back key on the mobile device, and tap yes in
the dialog. 
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5. Back to the map, and you can start to query. Tap Query toolbar > Attribute Query.
Then, the dialog shows up; please set the key words, value, or range. Or you can
fuzzy inquiry by entering some key conditions. Tap OK. 

    

6. The features that meet the conditions will
be displayed and panned to the map
center. 

7. Tap Identify Query on Query toolbar, and tap the feature you would like to query. The
results will be displayed on the map. 
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SuperGIS Server layers can be queried as the ordinary layers. All layers contained in
the SuperGIS Server layer will be listed for user to select. And the way to query
SuperGIS Server layers are the same as to query ordinary layers. 
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3.17 Measure Tools

In field survey,  if you would like to know the real length  or  area  on  the  map,  you  can
measure  with  the  tools.  Besides,  the  system  also  provides  the  function  to  measure
features. 

1. Tap Measure, and the measurement toolbar will show up on the right. 

    

2. Tap length measure   or area measure . 
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3. Tap the map to specify a
segment or area you would
like to measure. Then

measure  and undo

 will become enabled. 

4. Tap Undo , you can cancel the current measurement. 

5. Tap measure , the
system will calculate the
total length or area of the
segment or extent and
display the results on the
map. 
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6. Tap “Measure Feature ” and tap on point, line or polygon feature on the map to
respectively get the XY coordinates, length, perimeter and area. Users can also
measure SuperGIS Server layer features.

    

7. Tap Measure again, you can close the measurement toolbar.

Note:
Line measurement units include: meter and kilometer (the line longer than 1000 m
will be displayed with km); area measurement units include: square meter, hectare
(the area larger than 10000 square meters will be displayed with square hectare), and
square kilometer (the area larger than 1000 hectare will be displayed with square
kilometer)

The message below will show
up if you are measuring but
switch to different
measurement or tap finish
measurement. Tap OK and the
current measurement will be
canceled.



4
Detailed Function Description
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4 Detailed Function Description

4.1 An Overview of Functions

Setting Project

1. You need to create a project environment before starting to use system. The figure
below will show up when you first time start system. Please tap “OK.”
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2. Enter the name of the project and tap “Select” to choose the “Spatial Reference.

    

3. The coordinate systems provided by spatial reference include geographic coordinate
systems and projected coordinate systems. In addition, users can also build
customized coordinate system by importing PRJ file. Please choose the coordinate
system you need and click OK.
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4. The major system interface appears. 
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Adding Online Map Tool Project

Online Map can be used to be the basemap in SuperSurv project by creating a
SuperSurv Online Map Tool project. Internet connection is necessary to connect online
map, please confirm the Internet connection works.  

Tap "Online Map Tool Project" and tap OK.
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Enter the project name, Spatial Reference will be grayed out.

    

Tap the Map Type and a menu shows up. Choose one online map to be the basemap
and tap OK.
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Return to the map, Online Map shows.

    

If you need to use Google Map Online Map on SuperSurv, you need to install some
tool.  Before installing Google Map Online Map tool, please read carefully and
understand the use terms and conditions of Google Map(http://code.google.com/intl/en/
apis/maps/terms.html) and ensure you are licensed.

Go to Supergeo SGDN website at http://sgdn.supergeotek.com/download.aspx and
download SuperSurv 3.1a Online Map Tool_sud. In Search Downloads please check the
checkboxes as the picture below indicates.

    

http://code.google.com/intl/en/apis/maps/terms.html
http://code.google.com/intl/en/apis/maps/terms.html
http://sgdn.supergeotek.com/download.aspx
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Download SuperSurv 3.1a Online Map Tool_sud.

    

Please refer to the related document in SuperSurv 3.1a Online Map Tool_sud zipped file
you just downloaded for more details. 
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Major System Interface

The major system interface includes “map display”, “map toolbar”, “upper function list”
and “lower function list.” 

    

    
Tapping “Menu” button of the mobile device
will open a menu which allows you to open/
save project, create project, enter “Settings/
View” and “About.”
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In Settings/View page, you can use Map element and tap settings, Set base map, Set
map background, Set WMTS Server, Set SuperGIS Server, Use GPS, View Location
information, View project information, Dimension Setting (Measure Function). As to the
details of how to set these items please refer to Others. 

    

”About” shows the copyright and the software
version. You can exit by tapping “Close.” 
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In addition to the functions mentioned above, you can long-press anywhere on the map
to create a waypoint. When GPS is on and there are waypoints on the map, you can
tap the waypoint flag to show the guidance that connects GPS position and the
waypoint you tapped.  
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Function Description
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4.2 Map Toolbar

Zoom In

“Zoom In” enables users to zoom in the map by one level based on the map center.

1. Tapping “Zoom in ” will zoom in the map by one level. You can also zoom in
the map by the thumb and index finger or by double-tapping on the map.
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Zoom Out

“Zoom Out” enables users to zoom out the map by one level based on the map center.

1. Tapping “Zoom out ” will zoom out the map by one level. You can also zoom
out the map by the thumb and index finger.
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Full Extent

”Full Extent” will zoom the map to full extent.

1. Tap “Full Extent ” to zoom the map to full extent.

    

4.3 Survey

Create Layer

1. Tap “Survey”> “Create Layer.”
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2. The “Create a layer to survey” page
appears, please enter the name of the layer
file and layer and specify the code page,
layer type (point, line, polygon) and File
format (GEO, SHP), and tap “OK.” 

3. The setting dialog appears; please choose
the first item if you want to customize
table; choose the second item if you don’t
and tap “OK.” Here we illustrate “Start to
survey”, so you will not be able to edit or
modify the fields of the attribute table.
However, after you tap “OK”, the default
fields including ID, NAME, MEMO, etc. will
still be available. To manipulate the custom
table, please refer to Custom Table.    
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4. In the main map window, Survey toolbar appears at the top of the map in edit mode.

Tap  to expand the full Survey toolbar.   

    
   

5. ”Create by hand ” becomes enabled, and please create features by tapping on
the map based on the layer type (point/line/polygon). 
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Add Point Feature

1. Directly tap at the location where you want to add a point feature, and the point
feature is created.
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Add Line Feature

1. Tap at the locations where you want to add vertices for the line feature, and system

will auto-connect the vertices in a line. To finish the editing, please tap .
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Add Polygon Feature

1. Tap at the locations where you want to add vertices for the polygon feature. A
polygon must be created by three vertices at least, and system will auto-connect the
vertices in a line. The line will connect the last and first vertex, making it into a

polygon. To finish the editing, please tap .
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Undo/Redo

1. In edit mode, you can undo by tapping . To redo, please tap .
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Select Feature

1. You need to select a feature with “Select Feature ” first to edit an existing feature,
so you can delete, move, edit attribute or pan to a specified feature. Tap “Select

Feature ” and tap the feature you want to edit. After a feature is selected, the
Delete tool, Move tool and Edit Attribute tool become enabled.
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Delete Feature

1. After a feature is selected, tap “Delete feature ”, a confirming dialog shows up,
please tap “OK.” The feature is tapped.
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Move Feature

1. After selecting a feature, tap “Move Feature ”, and the feature will be in selected
mode: framed by dotted square. This tool allows users to move vertex, move feature,
rotate feature, zoom feature, insert vertex and delete vertex. Now we are going to
describe the five functions respectively. 

   

To move features, please press the dashed circle under the feature and move the
feature to the new position then release. After that, you will see the feature is moved to

the new location. Tap  and the feature is moved to the new location.  
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To rotate feature, long-press the dashed circle, as the blue circle appears, you can

rotate the feature with the  as pivot by finger. 
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Tap  at the lower right corner on the map as the feature is rotated to the required

position, and tap  on the editing toolbar to finish rotation.

    

As the blue circle appears, Rotate Feature is usable at the time but Pan and Zoom will

stop functioning. You can tap  to make blue circle disappear and restore Pan and

Zoom function with rotation function stopped. Tap  again and blue circle re-appears.

To zoom features, please press one of the four small squares outside the dashed
square that frames the editing feature. When the blue dashed line appears in feature,
move your finger to zoom the feature as required. Release your finger when the feature
is zoomed to the shape you desire.
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Now you can see the feature that is zoomed, tap   and the feature is modified as
the new shape.
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To move vertex, please press the vertex (the start vertex and end vertex are displayed
in red and green little square, while the rest vertices are displayed in little circle), when
the blue dashed line appears in feature, please move the vertex to the location desired
and release your finger.  

    

You will see the feature at the new location, and tap . The vertex is moved to the
new location.
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To insert vertex, firstly, long-press the small rhombus in the middle of the segment
between two vertices (it represents the mid-point of the segment) and a vertex (red
circle) will be inserted in the middle of the segment.
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Tap  and a vertex is added to the feature.  

    

To delete vertex, please long-press a vertex (the start vertex and end vertex will be
displayed in red and green square respectively, while the rest vertices are represented

with little circle). When  appears on the map, tap it and the vertex will be deleted. 
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Tap , the feature that has deleted a vertex will be shown on the map.
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Edit Attribute

“Input attributes after creating a feature” is On by default, so whenever a feature is
added, the attribute table page appears immediately for attribute data input. If you want
the attribute table page not to appear everytime you create a feature, you can set “Input
attributes after creating a feature” off. As to the setting steps, please refer to Set
Survey Toolbar. 

Here we illustrate the steps to edit attribute in the status of “Input attributes after
creating a feature” off.

1. Select a feature, tap Edit Attribute , and the “Enter attributes” page appears.
Please enter the attribute data. If you choose “Start to survey” when you create the
layer, you will need to enter the attribute value manually. Some attribute values will
be given automatically when creating the feature, such as date, time, XYZ coordinate
values (for point layer), length (for line layer), area(for polygon layer), but you can
change them manually. 
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If you have set the custom table, when you are editing attribute, the system will offer
you a quick way to input data based on the field type. For instance, in date field, you
can input data by tapping, and tap “Set.”

    

Navigate to Feature

1. Tap “Navigate to feature ”and a list with all features’ IDs appears. Please specify
a feature and tap “OK.”
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2. The specified feature will be pan to the map center.
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Collect Data with GPS Automatically

1. Before using this function, please make sure GPS works correctly. You can
continuously add points at GPS positions through the GPS data, which allows you
to add line or polygon features. Firstly, add a line or polygon feature, here we
illustrate with a line feature. Add the first vertex of the line feature, tap “Collect data

with GPS automatically ”. A message shows up:” Whether to collect data with
GPS automatically.” Please tap “YES.” 

    

2. When you are moving, the vertices will be added to the map based on the GPS data.

To stop collecting GPS data, tap again” Collect Data with GPS automatically .”

To finish the editing, tap , and you will see the new feature on the map. 
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3. For helping user to prevent unexpected vertex adding, SuperSurv 3.3 now embedded
with the smart screen-lock while user turn the the data collection via GPS
automatically. The screen-lock will apply when user start survey with GPS, and dismiss
when user turn off. Also, the screen-lock is capable to be disabled manually if user
need to add the vertex by touching.
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Add A Vertex at GPS Position

To add point features or vertices of line or of polygon features, you can tap “Add a

vertex at GPS position ” to add a point feature or a vertex (line or polygon layer) at
GPS location. Here we take editing a polygon feature for example. The new feature in
the figure below has three vertices already.

1. Tap “Add a vertex at GPS position .”

    

2. A vertex is added at the GPS
location. Tap, and the feature
is successfully created.
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Set Survey Toolbar

Tap , the survey toolbar setting page appears. Four items:
Input attributes after creating a feature: If set it On, the attribute table window shows
up right after a feature is created. If set it Off, no attribute table window shows up
after a feature is created; in that case, to edit attribute you need to select the feature
first and use “Edit Attribute”, so the attribute table windows will appear. 

Sampling time for collecting a GPS position: ”Add a vertex at GPS position” allows
users to add point features(point layer) or vertices(line/polygon layer) at GPS
locations. The item sets the sampling time for retrieving GPS location. The longer the
bar, the longer the sampling time. It has five levels: 1, 3, 5, 10, 15 seconds.

Interval for continuously collecting GPS positions: The system will add vertices with
GPS signals continuously by the default interval. This function does not influence

“Add a vertex at GPS position ” or “Add vertex by hand .”
Outline color when editing feature: Set the outline color when editing feature.

Snap to vertex when editing feature: When editing features, the new or editing feature
is able to snap to other existing feature within the specified tolerance. Users can
switch on/off the function, the unit is pixel.
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Please note that, to activate snapping when editing features, firstly, you need to set
“Snap to vertex when editing features” on and specify the tolerance. Sequentially,

proceed snapping via Move Vertex function with Move Feature tool .

SuperSurv allows snapping vertices with tolerance automatically. To snap two vertices,
please select the feature to snap and then activate Move Vertex function so that you
can pan vertex A which you want it to be snapped to vertex B by approaching to vertex
B. As the distance between the two vertices is shorter than tolerance (you set in Snap
to vertex when editing features, the unit is pixel), vertex A will be snapped to vertex B
automatically. Please refer to the illustration below. 
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Add a vertex by GPS average: The function used to collect and add point(s) or
vertices of point, line and polygon layer. 

Time: Please fill in the blank with a number which will stand for “the time interval
(second) for GPS to add a vertex.” Fill in with 1; the GPS adds a vertex every second.
Fill in with 2; SuperSurv will average the positions of the collected vertices every 2
seconds and adds the point/vertex on the map.

Position: The Point setting is for collecting point data while the Vertex setting is
applicable for collecting the vertices of line/polygon data. Please fill in the blank you
require with a number. Fill in with 1; the GPS adds every point it collected. Fill in with 2;
SuperSurv now averages positions of every 2 vertices it collected and adds the vertex
on the map.
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Continuous GPS Position: The function used to collect data (or vertices) of point, line
and polygon layer.

Time interval: Please fill in the Time interval with an integer which stands for “the time
interval (second) for GPS to add a vertex.” If you fill in with 1, SuperSurv will add its
position every second. Subsequently, fill in the blank of Distance with a number which
represents “the distance (meter) threshold for the data collection” Fill in with 1;
SuperSurv will add every next point while the distance among them is at least 1 meter.

Position interval: Please fill in the blank of Position interval with an integer which stands
for “the specified points collected by GPS.” Fill in with 1; SuperSurv will add every
collected point on the map. Fill in with 2; SuperSurv will add the even points it
collected. Subsequently, fill in the blank of Distance with a number which represents
“the distance (meter) threshold for the data collection”.

Note With SuperSurv M3, only Time of the Add a vertex by GPS average and Time
interval of the Continuous GPS Position are available. SuperSurv M3 users can unlock
the whole functions by purchasing the GPS Plug-in on Google Play Store. 
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Switch Editing Layer

1. You can solely edit one layer in editing mode in SuperSurv, so if you want to edit

other layers, please tap “Switch editing layer .” A message appears to confirm
whether you are sure to stop editing and switch to other layer to edit, please tap
“Yes.”
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2. The layer list appears, please select the layer to edit and tap “OK.” Now you can
start to edit the layer.

    

3. To stop editing, please long-press  or press the “Previous” button of the mobile
device. A confirm message appears, please tap “Yes” to stop editing. 
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Set Edit Layer

After adding layer to the map (refer to Add Layer ), if you want to edit layer, please
specify the layer to edit.

1.Tap “Survey” > ”Edit Layer.” 

2.The layer list shows up, please specify
the layer to edit and tap “OK.”
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3. Start to edit the layer on the map.

    

Note that the SuperGIS Server layer in SuperSurv will be listed for users to select to
edit. As the SuperGIS Server layer is selected to edit, all layers contained in the
service will be listed. Please select the editable SuperGIS Server layer in dialog for
users to specify the layer to edit. 
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Synchronizing Feature Service to Server

When editing SuperGIS Server layer, a message will show up to confirm whether you
want to synchronize data with Server after a feature is added, please tap Yes to
synchronize, otherwise, tap No.

    

After inputting attribute data in Enter attributes dialog, please tap OK(Synchronize) to
synchronize the attribute data with Server.   
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4.4 Manage Layer

Add Layer

After the layers are created, you can add layers to the map. 

1. Tap “Layers”>”Add Layer”, the layer list shows up, select the layers to display and
tap “OK.”

    

2. The layers that are checked are
displayed on the map.
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Layer Setting

You can set the overlapping order of layers, symbol style, size and color with “Manage
Layer.” Tap “Layers”>”Setting” and the layer setting page appears.  

    

All layers will list in this page; from top to the bottom is the overlapping order of layers.
In general, from top to the bottom should be point-line-polygon, so the point/line layers
will not be covered by polygon layer. You can long-press a layer that you want adjust
order and drag-and-drop the layer.

    

Select a layer, the layer setting page appears. You can change the layer name or
change the symbol style by selecting a style in “Use Default Style.” 
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Or you can select other style by tapping the first item in ”More Settings.” To polygon
layers, you can decide the frame and fill pattern.
   
    

Set the width of line by tapping “Size.”
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Switch On Label Setting within Layer Setting, you can set label to be displayed on

map. Please tap  icon 

  



Detailed Function Description

118

Afterwards, select the field you require from the drop-down menu within the pop-up
dialog. Please notice that you can only select one field per time.
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Using the defaults that are already set, labels on map will be neither overlapped nor
duplicated.When there are labels  duplicated, only the upper one will be displayed on
map. And each overlapped label will be rearranged in a clockwise direction 
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Ticking Allow Overlap, labels are allowed to be overlapped on map.

  

Ticking Allow Duplicate, labels are allowed to be duplicated on map.

NOTE: If Allow Overlap is not ticked, duplicated labels will not be overlapped but
rearranged in a clockwise direction.
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When ticking both Allow Overlap and Allow Duplicate, same labels can be
displayed concurrently and overlapped on map. 
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You can decide color by tapping “Color.” The “Pick color” page appears and you can
choose from the 20 basic colors in the right side or from the color block in the middle.
The “Transparency” allows you to set the transparency by percentage. The higher
percentage value makes the more transparent effect. Confirm the settings, and tap
“OK”. Now you will find the overlapping order of layers and symbol style, color, size of
feature displayed on the map are as your settings.

    

In Layer Setting page, base maps in SGT format and SuperGIS Server layers have
different settings from general layers. Please see the figures below, except for the File
name and Resource of the layers are unable to be changed, layer name and
transparency are able to be changed. 
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In Layer Setting page, the Online Map will be allowed to change map type.
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Custom Table

A custom table used to enter attribute values is a quick menu that is particularly
designed according to the features of the attribute to enable users to quickly enter
attribute values. For instance, there is a layer whose contents of attribute table should
be input in date format, in that case, the field format can be set as YYYY/MM/DD with
custom table. While users are editing the field, they can select a date by tapping
instead of typing each word. We will introduce each field type in this section. Each field
type has Field Name and Note. Field Name must be English or number, which is the
name recorded in the file; Note is the name displayed on the interface for users to
identify and input data, which can be any language or simple description to help users
easily know what the field records. They both are field names, the difference stands in
one is the name recorded in the file, while the other is used to be displayed for users to
read.

1. Tap “Layers”>”Table”, the layer list appears. Please select the layer to customize
attribute table.

    

  
Please note that you can customize the attribute table only when no feature and no
attribute data has been created in the layer. If the layer already has features, the below
message will appear to inform that you cannot adjust fields. 
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2. If you select “Start to customize table” in the beginning of creating layer, you can
follow the below steps to continue, because it works in the same way as “Custom
Table.” The “Create a new layer” page appears with multiple default fields. First
column is field name and the second column is field property. 

    

3. To add field, please tap , and a list of all field types appears. 
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4. Select a field type, the field setting page appears. Enter the field name and field note
and set up the property. Now we will introduce the property and effect of all types of
field.

Text: It is string, and should be input attribute value manually. Please set the length of
the field, the unit is bit.
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When you use “Edit Attribute”, you will enter the “Enter Attributes” page. To this type of
field, you need to enter the attribute value manually. 
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Date: The system will show the date automatically, or you can change it by tapping.
Four types of data format are available YYYY/MM/DD, MM/DD/YYYY, MM/DD and DD/
MM/YYYY.

    

When you use “Edit Attribute”, you will enter the “Enter attributes” page. To this type of
field, the system will automatically show the date. To change the date, you can directly
tap the icon and set.
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Time: They system will automatically show the time or you can change by tapping.
The time format includes 12 HR and 24 HR.

    

When you use “Edit Attribute”, you will enter the “Enter attributes” page. To this type of
field, the system will show the time automatically. To change time, please tap the icon
and set.   
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Photo: The attribute value is a path of photo. You can select a photo file or take a
photo with the camera device of mobile device, and the path of the selected file or of the
photo you just taken will be shown in the field. The photo you take in SuperSurv will
have GSP data and will be saved in the PHOTO folder of project folder.  

    

When you use “Edit Attribute”, you will enter the “Enter attributes” page. To this type of
field, you can choose a photo or take a photo. Tap the field and a dialog shows up, you
can select choose a photo or camera. 
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Tap “Choose a photo”, specify a photo file and the path of the photo file will be input
automatically. 

    

Choose “Camera”, it enters camera mode. After you take a photo, the path of the photo
file will be automatically shown in the field. The coordinate values will be saved to the
file and photo file will be saved to the project folder. 
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GPS: The system will automatically record the GPS coordinates of the position of the
feature or you can change manually. You need to specify the XYZ value. Please note
that this type is available for point layer only

    

When you use “Edit Attribute”, you will enter the “Enter attributes” page. To this type of
field, the specified coordinate value will be recorded as the attribute value.
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Length:the system will calculate and record the length of the line feature as the
attribute value or you can change manually. Please note that this type is available for
line layer only. 

    

When you use “Edit Attribute”, you will enter the “Enter attributes” page. To this type of
field, the length will be recorded as the attribute value, the unit is meter. 
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Area: The system will calculate and record the area of the polygon feature as the
attribute value, or you can change manually. Please note that, this type is available for
polygon layer only.

    

When you use “Edit Attribute”, you will enter the “Enter attributes” page. To this type of
field, the area of the feature will be recorded as the attribute value, the unit is square
meter.
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Numeric: The attribute value should be an integer and input manually.

    

When you use “Edit Attribute”, you will enter the “Enter attributes” page. To this type of
field, you need to input an integer as the attribute value.

    



Detailed Function Description

136

Menu: When you are entering the attribute value, the field will provide with a menu or
automatically filter the text that is entered and display the suitable one for users to
choose.    

    

Tapping  can add the menu item, and the window of figure below will appear for you
to enter the name of menu item.

    



SuperSurv 3 Help

137

If you choose Menu, when you use “Edit Attribute”, you will enter the “Enter attributes”
page. To this type of field, you can tap the drop-down menu and choose one item as
the attribute value.      

    

If you choose AutoComplete, when you use “Edit Attribute”, you will enter the “Enter
attributes” page. To this type of field, you need to enter the attribute value manually,
and system will auto-filter and present the suitable one for you to choose. Then, you
can just tap the one that matches.    

    



Detailed Function Description

138

In addition, when you are editing the field, in the “Create a new layer” page, you can
long-press a field and a menu appears. With the menu, you can tap “Delete” to delete
the field; tap “UP” and “Down” to change the order.

    

Video: The attribute value is a video file path. Users can select a video file or record a
video with the device’s built-in recording function. As the file is specified or video has
been recorded, the video file path will be presented as the attribute value. The file format
supports what the device supports. 
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When you use “Edit Attribute”, you will enter the “Enter attributes” page. To this type of
field, it shows “Choose a video or record a video”, tap it and a dialog shows up with two
options: choose a video or record a video.

    

If you want to choose a video, please specify a video and the file path will be presented
in the field. If you choose record a video, the device will switch to video mode, when the
video is finished, the file path for the video will be presented in the field.
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4.5 GPS

GPS functions enable you to rapidly recognize the current position when you are
surveying outdoor. With Waypoint, the status bar can show the guidance (refer to 
Waypoint). With track, users can record the path users passed by (refer to Track).
GPS functions include whether to user GPS, GPS position, and View location
information. 

SuperSurv supports to position with GPS by using satellite or using internet. If you are
in a area where the mobile device can receive satellite signal well, SuperSurv will

position with satellite and display GPS position with  on the map. If the satellite
signal is poor, SuperSurv will start AGPS function automatically to help find the GPS
position. 

Whether to Use GPS

1. Tap Menu key > Settings/View > GPS Settings.  

    

2. Tap the drop-down menu and choose Internal GPS to activate location service of your
mobile device.
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3. Back to Settings/ View page, tap Back key, and the message shows up. Tap Yes,
the changes will be saved; tap No, the changes will be canceled. 

    

4. When the status bar on the top of the map displays , it means the mobile device

is receiving GPS signal. The current GPS position will be displayed with , and
the fan-shaped area is the visual angle. Moreover, GPS status bar will appear on the
top of the map. The status bar displays the coordinates of current position; tapping
the status bar can switch longitude and latitude to projected coordinate system. 

    

Note:
After using GPS, you can use waypoint guidance and track record to help you have
the guidance and track recording.
If GPS is not used or no GPS signal is poor, waypoint guidance will be closed, track
recording function will be stopped as well.
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GPS Positioning

GPS Positioning allows to place GPS current position to the map center according to
the current scale. The function only works when GPS is used. If you have not used
GPS, please refer to Whether to Use GPS. After GPS positioning works successfully,
you can see the coordinates of the current position on the GPS status bar on the top of
the map. 

1. Tap GPS positioning on the toolbar. 
   

    

2. According to the current scale of the map, SuperSurv pan the GPS position to the
map center. The GPS status bar displays the coordinates of the current position.
You can tap the blank of the bar to switch longitude and latitude to projected
coordinate system and GPS status. 
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You can also have GPS show your current position and GPS position remain in map
center.

1. Users can choose a GPS signal through GPS Settings. You can setup the detailed
positioning data source you need, and SuperSurv is using Internal GPS signal as
default.
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For using the external positioning sources, SuperSurv 3.3 allow user to connect to
various of external GNSS receiver via Bluetooth communication. Please make sure the
Bluetooth function had been turned on and already finish pairing with the external
GNSS receiver. (Please notice: If you occur any trouble while pairing the Bluetooth
external GNSS receiver with your Android device, we suggest you contact your
hardware provider for further support.)
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Next, please select the type of your external GNSS receiver. If the device you are using
is the basic or consumer type of GNSS and will output the NMEA automatically, please
select the General Device. If the device you are using is the mainstream profession
high-accuracy GNSS receiver and is supported by SuperSurv, please select the
corresponding option in the drop down list.
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Now you can select the Bluetooth GPS in the Signal Source drop down list, and
SuperSurv will start linking to the external Bluetooth GNSS receiver automatically. Start
positioning and survey with your external Bluetooth GNSS device now!
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If your external Bluetooth GNSS receiver support NTRIP service and RTCM, you can
simply setup the detailed settings and apply the linkage. Now SuperSurv 3.3 support
about 80% GNSS module from 3 mainstream manufacturers: U-Blox, Hemisphere and
NovAtel. After you enter the IP and Port of your NTRIP service caster, tab on the Get
MountPoint button to receive the service list and select the option you want to apply
with. After finishing setup, turn on the NTRIP service and SuperSurv will automatically
receive the RTCM data and sent them to your external GNSS receiver via Bluetooth
communication. If the RTCM data could be solved by the GNSS module, you will be
having more accuracy positioning data for your field work.
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2. Switch On Auto Position, and configure the distance in that you require the GPS
position to refresh on map (please refer to the red circle on the left figure).

  

3. Tapping OK to complete the configuration. And you can view GPS position refreshed
automatically on map in traveling.
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View Location Information

The information related to GPS satellite contains General, Details, and Satellite. The
information can be viewed only when GPS is being used. 

1. Tap Menu key > Settings/View > View location information. 

    

2. View location information. 
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(1) Details

    Location source: to get the location source

Date/Time: date and time

Longitude: longitude position

Latitude: latitude position 

Altitude: the altitude calculated from sea level

Speed: the speed your move

Azimuth: the azimuth you move

(2) Satellite

    

The satellite information lists the numbers of the
satellites, azimuth, elevation, and noises.
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(3) NMEA

The protocol, made by National Marine Electronics
Association, NMEA, is used to define the communication
among data and data format. Tap Save, you can save the
data as a file in txt format.
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(4) General

The number in the circle means the number of satellite. 
The red one stands for weak signal so that GPS will not
use this satellite to calculate your current position.  The
green one stands for strong GPS signal, and GPS will use
the satellite to calculate your current position.

The blue bar means the satellite signal is strong enough,
and GPS will use the satellite to calculate your current
position.  If there is no bar for a satellite, it means no
satellite signal or weak signal.  Thus, GPS will not use the
satellite to calculate your position. 

You can view the common GPS information here. 
Longitude: the longitude position you are. 
Latitude: the latitude position you are.
Altitude: the altitude of the position you are.  The way to
calculate is from the sea level; the unit is meter.
Speed: the speed your move
PDOP: Positional Dilution of Precision
HDOP: Horizontal Dilution of Precision
VDOP: Vertical Dilution of Precision
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4.6 Waypoint

There are two ways to create waypoints: you can select a file and import waypoints or
create new waypoints on SuperSurv. As the waypoints are created, the waypoint
guidance will appear. The waypoint guidance can help users to know the position you
are and where the destination is. Moreover, users can pan to, edit, delete, export, and
import waypoints. 

Create Waypoints by GPS

1. Tap Waypoint > by GPS. 
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2. In Add Waypoint page, please specify the coordinate system, and the system will
directly enter XYZ value according to the coordinate system of the project. Also, you
can modify the coordinate system and manually enter XYZ values. In Name, enter
the waypoint name. After setting, tap OK. 

    

3. Back to the map, a new waypoint is created on the GPS position. 
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Waypoint Management

How to create waypoint file?

You can create waypoint files on PC and then copy the files to the mobile device. Then,
you can import the waypoints to SuperSurv. SuperSurv supports to import waypoints in
TXT, CSV, or KML file. If you use TXT and CSV format, please follow the rules below: 

Column names: the order is Name, X, Y, and Z. They stand for waypoint name, X
coordinate, Y coordinate, and elevation. 
Punctuation: use comma“,” to split each column. 
Coordinate system: XY coordinates can be projected system or WGS84 format. If
you use WGS84, please use degree. 
Z value: Z value is the elevation of waypoint. The unit is meter. Z value is an optional
column; you can choose whether to enter the value.

    

Importing Waypoint

Users are allowed to importing waypoints to SuperSurv. The system supports to import
TXT, CSV, or KML format; the imported XY coordinates can be displayed as points to
help you recognize the actual positions of the points on the map. In SuperSurv, the

waypoint is displayed with . 
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1. Tap Waypoint > Manage. 

    

2. In Manage Waypoint page, tap Import. 
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3. Select the waypoint file (supports TXT, CSV, and KML). Tap OK. 

    

4. Back to Manage Waypoint page, the waypoints are listed on the left. Tap Back key,
and the message will appear, and tap Yes. 
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5. You can see the imported waypoints. 
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Adding Waypoints

Besides importing, you also can add waypoints in the system .

1. You can long-press on the position where you would like to add a waypoint, and then
tap the icon. 
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2. Add Waypoint page appears. Select the coordinate system and enter the waypoint
name. The coordinate system columns (X, Y, Z or longitude, latitude, altitude) will
show the coordinates of the position. Also, you can manually modify the values in
the 3 columns. Tap OK to finish the setting.

    

3. Back to the map, the waypoint icon appears, and it means the waypoint is
added. 
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Steps to disable the long-press manipulation for adding Waypoints are:

1. Tap Settings/View ’  Map element and tap setting

           

2. Set Waypoint setting as Off, tap the Back Button and save the changes; now the
long-press manipulation for adding Waypoints function is disabled. Subsequently, tap
the back button again to head back to the map.
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Edit/Delete Waypoint

Manage Waypoint page list all the imported and added waypoints. You can edit, delete,
import, and export the waypoints. The following describes the way to edit and delete. 

1. Tap Waypoint > Manage. 

    

2. Manage waypoint page appears. You can select the waypoint you need on th left
and then tap the items on the right to edit the waypoints. If no waypoint is selected
and you tap an item on the right, the message will appear to remind you to select a
waypoint. 
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Edit: You can edit the name, longitude, latitude, z value (altitude) of the selected
waypoint. 

1. You can select a waypoint to edit; the selected waypoint will be marked with green. 

2. Tap Edit. 

    

3. Waypoint page appears; you can edit the name, longitude, latitude, and z value
(altitude). 

4. Tap OK to complete edit. 
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Delete: Delete the selected waypoint. 
1. Select the waypoint you would like to delete. The selected waypoint will be marked

with green. 
2. Tap Delete. 

    

3. The warning message appears, “Are you sure to delete the waypoint?” 
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4. Tap yes, and the waypoint will be deleted. Tap Back key, the message will appear,
“Do you want to save the waypoints?” Tap Yes. 

    

Delete All: Delete all the waypoints. 
1. Tap Delete All. 

    

2. The warning message will appear, “Are you sure to delete all waypoints?” Tap yes. 
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3. Back to Manage Waypoint page, you can see all the waypoints are deleted. Tap
Back key, and the message will appear, “Do you want to save?” Then tap yes. 

    

Note:
Deleting waypoints only deletes the added and imported waypoints that will neither
delete the original waypoint file nor modify the data in the file.



SuperSurv 3 Help

167

Show Waypoints

You can choose whether to show the waypoints  on the map. If you check Show
Waypoints, all the waypoints and waypoint names will be displayed on the map. If
Show Waypoints is not checked, no waypoint will be displayed on the map.
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Exporting Waypoints

Through exporting waypoints, you can export all the waypoints (including the imported
waypoints and newly added waypoints) as TXT, CSV, or KML files. And the waypoints
can be used for further application. 

1. Tap Waypoint > Manage. 

    

2. Tap Export in Manage Waypoint page. 
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3. File saving page appears. You can set the directory for saving waypoint, file name,
and the file type. SuperSurv support to export files to TXT, CSV, and KML format. 

    

4. As the waypoints are exported successfully, the message will appear. 

    

Note:
If there is no waypoint in the system, the message “There is no waypoint” will appear.
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Pan to

The selected waypoint will be panned to the map center according to the current map
scale.

1. Tap Waypoint > Pan to, select the waypoint you would like to pan from the list, than
tap OK.

    

2. Back to the map, the waypoint is panned to the map center and displayed in green. 
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Waypoint Guidance

As GPS is used, you can select a waypoint as the destination of the waypoint guide.
The system will calculate the shortest straight line distance between the current GPS
position and waypoint; an orange dashed line will be connected between the two points
on the map. Also, the information of waypoint guidance will appear on the top of the
map and guide the users to the destination. 

1. Tap the waypoint you would like to see the guidance. 

2. Or you can tap Waypoint > Guide, select the waypoint you need from Guide to
Waypoint page. 

                      

          

3. If you adopt Step 1, Guide to waypoint message appears. Tap Yes, an orange
dashed line will appear and connect the current GPS position and waypoint. The line
is the shortest straight line distance. Guidance information will appear on the top of
the map, and the information includes the waypoint name. Tapping the blank of the
guidance information can switch the distance and azimuth. If you tap NO, you will go
back to the map. 
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Guidance information includes:  
(1) Waypoint name
(2) Switch to the shortest straight line distance between current GPS position and
waypoint destination
(3) Switch to waypoint guidance
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Tap , you can switch to GPS information; tap , and you can
switch to the waypoint guidance. If the system does not receive GPS signal, the
waypoint guidance will not appear. The message will appear. 

    

4. If you would like to clear waypoint guidance, tap Waypoint > Guide, Waypoint
Guidance page appear. Select “Waypoint guidance clear”, and the guidance will be
cleared. 
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AR

Activate AR(Augmented Reality), the waypoints which are located within 700 meters
away from the GPS position will show up as a tag with waypoint name and distance.
And the radar at the upper right corner shows to identify the relative direction in
between all waypoints.

    

4.7 Track

Track functions include “track recording” and “Import/ close reference track.” Track
recording helps you record the path you pass by outdoor, and the track can be used for
further application. Or next time when you are in field survey, you can apply display
track on the map for references. The detailed functions will be described below. 

Start to Record Track

“Start to record track” enables you to record the track received by GPS and helps you
know the path you pass by. 

1. Tap Track > Record, and track toolbar appears on the right. 
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2. Tap , and the system starts to record GPS positions. As you start to record, the
message on the upper-left corner will appear and mean recording track. The
message “Start to record” will appear. 
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Pause/Start to Record

“Pause/start to record” enables you to pause to record track and start to record track
after pausing. In a survey, if you pass some areas where GPS signal is weak (e.g.

tunnel, forestry), you might want to pause to record. Then, you can tap  on the
upper-right corner, the track record will be paused. The upper-left information will be 

. When you want to keep recording, please tap , the upper-left

corner will become  and the system keeps record. You can tap 

and  more than once, but the track will be saved in the same file. 

Stop Recording

When the system is recording track, you can stop recording anytime. Tap , the
system will save the current track. The upper-left information will become 

. The file will be named with year, month, date, and order. The file can
be saved as point layer (*.kml and line layer (*.shp. The file will be saved in the Track
folder in the project folder.   

In addition, after stopping recording, the Tracking Record Finish Length will display
on screen. To close track recoding function, please tap Track > Record again.
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Note:
The track file is named with YYYYMMDD_XX YYYY is year; MM is month; DD is
date; XX is the order of the files created on the same date. The number starts from 01.
For example: 20110328_02.

    

Import Reference Track

Reference Track allows you to import the saved track file (the file format should be
SHP), and the map can be panned to the track. 

1. Tap Track > Reference. If there is no track file in the folder, the message “there is no
available track” will appear. 

    

2. The window “Import reference track” appears. Select the track file you would like to
import and tap OK. 
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3. Import reference track, and the map will be panned to the track and displayed with
purple line.

   

Close Reference Track

“Close reference track” can clear the imported reference track on the map. As the
reference track is imported, you can close the reference track anytime. 

1. Tap Track > Reference. 

    



SuperSurv 3 Help

179

2. Tap “close reference track” in the menu, and tap OK. 

    

3. The imported track is cleared. 

    

4.8 Query

The system provides 2 methods to query: Attribute Query and Identify Query. If you
would like to use Attribute Query, you need to set the conditions first. Then, the feature
(s) that meet the conditions and its attributes will be displayed on the map. Attribute
Query only allows users to query a single layer. If you use Identify Query, you need to
specify the fields you would like to query. Then, tap the feature you would like to query,
and the results will be displayed on the map. Identify Query allows users to query
multiple layers. If you would like to use query function, please set the layer and fields
first. SuperGIS Server layer (Feature Service) is able to be queried as ordinary layer.
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Set the Layer and Field

1. Tap Query. 

    

2. Query toolbar appears on the left. Tap Settings. 

    

3. In “Set Query Conditions” page, tap Setting below Attribute Query. The layer menu
appears and SuperGIS Server layers will also be shown on the menu. Please select
the layer you would like to query and then tap OK. Please note that Attribute Query
only allows users to query a single layer. 
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4. Then, the layer you select is below Settings. Tap the layer, the menu shows up and
asks users to select the field(s). Or you can tap “Select all fields” to select all fields
at a time. Tap OK. 
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5. Like the steps described above, you can set the layers and fields for Identify Query.
But the difference is Identify Query allows users to query multiple layers so that
users need to set the field(s) for each layer. After setting, tap Back key. The
message “Do you want to save?” appears. Tap Yes.    

    

6. Setting is finished. 

Attribute Query

1. Tap , and the query conditions window appears. Please enter the conditions, or
use fuzzy inquiry, and tap OK. 
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2. The feature(s) that meet the conditions will be marked, and the attributes of the
features will be displayed. 
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Identify Query

1. Tap  and tap the feature you would like to query, and the feature will be marked.

If you want to cancel identify query, please tap . 
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Hyperlink Query

Querying with hyperlink enables you to access files in diverse formats on SuperSurv,
including video, photo, website address and document. And the available formats for
document accessing include PDF and TXT.

Here is the example of accessing website address on SuperSurv:

1. On page of editing attribute of a feature, you can enter the specified website address
manually. (To know how to edit feature attribute, refer to Edit Attribute.) 

 

2. Tap Query. 
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3. Tap  on the query tool bar and set Hyperlink Setting on Set Query Condition
page.Tap Settings within Hyperlink Setting to select the layer you intend to query
and tap OK. You can see the selected layer(s) listed on screen. While selecting the
layer, you can select all layers and switch to the one you intend to query each time.
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4. Tap the layer you intend to query and configure hyperlink settings (In the sample
here, we select Poilink). In drop-down menu of Hyperlink Field, select the field you
entered hyperlink while editing feature attribute, such as Link. And select the file
format you intend to query and access on SuperSurv in drop-down menu of Field
Type, such as Web. To finish and save the configuration, please tap OK and then
Back icon of the device.
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5. Tap  and tap any feature on the selected layer. And the website address
configured in attribute of the feature will be displayed on the screen.
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4.9 Measure

The measure tools provide length measurement and area measurement. The units for
length measurement include meter, kilometer, mile, and feet. The units for area
measurement include square meter, hectare, square kilometer, square feet, and acre.
To know how to switch between metric units and imperial units please refer to  
Dimension Setting(Measure Function). 

Length Measurement

While manipulating with SuperSurv, you can measure the map anytime. 

1. Tap Measure. 

    

2. Measurement toolbar appears on the right. 
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3. Tap Length Measurement .  

4. Tap the map repeatedly to draw the segment you would like to measure. The
segment you draw will be displayed as a red line. 

5. Tap Undo , and you can undo the pervious measurement. 
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6. Tap Measure , and the system will calculate the total length of the segment you
draw on the map. The results will be displayed on the map. If you want to measure
another line, you can tap the map to start anther measurement.

    

Area Measurement

While manipulating with SuperSurv, you can measure the map anytime.
 
1. Tap Measure. 
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2. The measure toolbar appears on the right, and then tap Area Measurement .

    

3. Tap the map repeatedly to draw an area you would like to measure. The area will be
framed with red lines. 
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4. Tap Undo , you can undo the previous measurement. 

    

5. Tap , and the system will calculate the area of the rectangle you draw on the
map. The measure results will be displayed on the map. If you would like to measure
another part, you can tap the map to start another measurement.
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Feature Measurement

This tool allows you to measure features. To SuperGIS Server layer features, Feature
Measurement tool also works on it.

1. Tap Measure>Measure Features .

    



SuperSurv 3 Help

195

2. Tap on the feature you want to query and the result shows up in different type
depending on the feature type.

    

Note:                                                   
The length units include: meter and kilogram. (The length longer than 1000 m will be
displayed with km.)
The area units include square meter (the area larger than 10000 square meters will
be displayed with hectares), hectare, and square km (the area larger than 1000
hectares will be displayed with square kilometers). 
The message below will show up if you are measuring but switch to different
measurement or tap finish measurement. Tap OK and the current measurement will
be canceled.
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4.10 Use Camera

Camera function enables you to use the camera of the mobile device. The function only
works if your mobile device is equipped with camera. Tap the camera on the upper-right
corner to turn on the camera. When you are in field survey, you can apply this function
to record the environment around the survey point. This function can record the
coordinate information to EXIF information of the photo as GPS is being used. 

1. Tap Camera on the upper-right corner. 

    

2. Turn on camera, and you can take photos. 

    

3. After the photo is taken, Exif Tag window shows up. As GPS is being used, the
coordinates will be entered directly. Also, you can enter the valued manually. 

4. The photo will be saved a JPG file in the Photo folder in the project folder. You can
view the photo you take in the folder.
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5. Tap Update to complete. 

    

4.11 Others

Tap Menu, and you can see the menu including “New Project”, “Open Project”, Save
Project, “Settings/View”, and “About.” You can create a new project, open a project,
and save the project. “Settings/View” includes the settings of base map and location
information. Users can set the base map, background color, use GPS, location
information, project information, Dimension Setting (Measure Function) etc. 
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New Project

Enter the project name and set the spatial reference to create a new project. 

    

Or create a Online Map Tool Project which has online map as the basemap.
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Open Project

You can open the existing project. As the menu shows up, you can select a project,
and tap OK. 

    

Save Project

You can save the project. If you leave the system without saving, the system will save
the project for you. 
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Settings/View

Tap Settings/View and you can setting 8 items.

Map Element Setting

You can set whether to display north arrow, scale, visual angle and to activate snap
tolerance.
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The top of the map always points to the north, but the aspect of the actual environment

might not be the same. At the moment, you can tap the north arrow  on the map to
show the electronic compass to indicate the north aspect of the current environment.  
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Snap tolerance takes effect in Query, Waypoint and Measure, which allows users to
select the needed position more flexibly while manipulating. The unit is pixel. Take
Identify query as an example. See the figure below that the center of the circle is where
the query tapping is performed. If the tolerance is 5, the point feature is located outside
the query range, so it will not be performed query; if the tolerance is 10, the point
feature is inside the query range, so it will be performed query.
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Set Base Map

Please specify the path of SGT layer or STC layer. The coordinate system of the SGT
Layer or STC Layer should be the same as the one of the project. Please tap OK. Back
to Settings/View page, tap Back key. The message, “Do you want to save?” appears,
tap Yes.
    
    

The way to create STC project file, please refer to SuperGIS Desktop or SuperGIS
Server User Guide.

Set the Background Color

You can specify the color of the area outside the base map; you can choose from the
20 basic colors or from the middle area. Current Color displays the color you choose.
Besides, you can set the transparency by dragging the bar. The higher the percentage
is, the more transparent the color is. After setting, please tap OK. Back to Settings/
View, tap Back key, the message will appear. Tap Yes. 
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Apply the background color to the map. 
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SuperGIS Server Settings

You can download SuperGIS Server map service to use in SuperSurv as long as you
finish the SuperGIS Server settings and successfully connect to it. In SuperGIS Server

Settings page one connection file is provided by default. Or you can tap  to add a
new connection file. 

    

Then select a connection file and operate with the tools above.

: Delete the selected connection file.

: Edit the selected connection file, input data and click OK.
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: Set as the default conneciton file. More than one connection file can be created,
but the conneciton file you want to connect must be set as default so that the
SuperSurv can successfully connect to the right server. Select a connection file, tap 

 and you can see the screen shown as picture below. At the time, the selected
server is the default one. 
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In the next, tap  and a default service list shows up. Select the map service to
download to SuperSurv and tap OK.

    

Back to the map, the map service is added to the map.
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You can directly tap SuperGIS Server connection tool  at the top of the screen to
connect to server if the SuperGIS Server connection settings are set up. To cancel the

connection to Server, simply tap .

After SuperGIS Server map service is downloaded to SuperSurv, switch to Add Layer,
the SuperGIS Server map service will also be listed on the layer list. You can set up the
layer name and transparency by tapping Manage Layer>Layer Settings>Map Service.
Users can also query all layers contained in the SuperGIS Server Service, and to those
editable SuperGIS Server services, the layers contained can be editable as well and
you can even synchronize the editing to Server. 

   

Setting WMTS Server

Input the WMTS service address in URL, tap Get Layer(s), when the layer name shows
in Layer, tap the downward arrow to show layer menu and select the layer you want to
add to SuperSurv. If account and password are required to access the service, please
enter both of them; if not, just ignore them.
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If you want to access TIANDITU, we suggest you to modify Tile DPI and set it between
95 and 96. As to the other WMTS services, please maintain the default value as 90.71.
To modify the Tile DPI, please uncheck Modify Tile DPI first and change the value. As
the value is changed, check Modify Tile DPI to finish it. Tap OK and save settings.
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Return to the map and you can see WMTS service displays on the map.

    

Note Before using the WMTS connection, please make sure that the coordinate
system setting of your SuperSurv project is matched with the target WMTS service.

WMS Settings

Input the WMTS service address in URL, tap Get Layer(s), when the layer name shows
in Layer, tap the downward arrow to show layer menu and select the layer you want to
add to SuperSurv. If account and password are required to access the service, please
enter both of them; if not, just ignore them.
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If you want to access TIANDITU, we suggest you to modify Tile DPI and set it between
95 and 96. As to the other WMTS services, please maintain the default value as 90.71.
To modify the Tile DPI, please uncheck Modify Tile DPI first and change the value. As
the value is changed, check Modify Tile DPI to finish it. Tap OK and save settings.
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Return to the map and you can see WMTS service displays on the map.

Note: Before using the WMTS connection, please make sure that the coordinate
system setting of your SuperSurv project is matched with the target WMTS service.
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Use GPS

Users can choose a GPS signal through GPS Settings. Tap the drop-down menu of
GPS Signal and you can find all the options which include GPS Off, Internal GPS and
Bluetooth GPS.
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View Location Information

You can view the information related to the current location, including General, Details,
and Satellite. 

    

View Project Information

Provide the information related to project name, path, spatial reference, etc.
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Dimension Setting(Measure Function)

Set to display the measurement result in
metric units or imperial units.

Quick Start Guide

For helping user to make the
best use of SuperSurv, Quick
Start Guide had been built up
and offer various information
about SuperSurv and field
survey. User can decide
whether the Quick Start Guide
to be shown or not while open
up the project. Moreover, user
are also allow to turn on the
Quick Start Guide in the setting
page anytime during usage.



Detailed Function Description

216

About

Tap Settings >
About to view the
version and
copyright of the
system. 

Exit System

Tap Back key, and the message will
appear to ask you whether to exit the
system. Tap OK, and the system will
close.
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